Skip to content
This repository has been archived by the owner on May 20, 2023. It is now read-only.

Commit

Permalink
upgpkg: llvm 8.0.0-2
Browse files Browse the repository at this point in the history
Rebuild with GCC 8.3; fixes segfaults in clang's /usr/bin/modularize.

Some further explanation at the link bellow:

  MaskRay/ccls#363 (comment)

git-svn-id: file:///srv/repos/svn-packages/svn@352148 eb2447ed-0c53-47e4-bac8-5bc4a241df78
  • Loading branch information
foutrelis authored and svntogit committed Apr 26, 2019
1 parent 9f96a20 commit 283d6ab
Show file tree
Hide file tree
Showing 2 changed files with 33 additions and 1 deletion.
27 changes: 27 additions & 0 deletions trunk/0001-Fix-the-buildbot-issue-introduced-by-r351421.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,27 @@
From 0b88c7b4a4e23dc5f8973095eb99d274f69a2b25 Mon Sep 17 00:00:00 2001
From: Sanjin Sijaric <ssijaric@codeaurora.org>
Date: Fri, 18 Jan 2019 19:34:20 +0000
Subject: [PATCH] Fix the buildbot issue introduced by r351421

The EXPENSIVE_CHECK x86_64 Windows buildbot is failing due to this change. Fix
the map access.


git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@351577 91177308-0d34-0410-b5e6-96231b3b80d8
---
lib/MC/MCWin64EH.cpp | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/lib/MC/MCWin64EH.cpp b/lib/MC/MCWin64EH.cpp
index 8bc1f08c8875..3ef1514455af 100644
--- a/lib/MC/MCWin64EH.cpp
+++ b/lib/MC/MCWin64EH.cpp
@@ -522,7 +522,7 @@ static void ARM64EmitUnwindInfo(MCStreamer &streamer, WinEH::FrameInfo *info) {
if (MatchingEpilog) {
assert(EpilogInfo.find(MatchingEpilog) != EpilogInfo.end() &&
"Duplicate epilog not found");
- EpilogInfo[EpilogStart] = EpilogInfo[MatchingEpilog];
+ EpilogInfo[EpilogStart] = EpilogInfo.lookup(MatchingEpilog);
// Clear the unwind codes in the EpilogMap, so that they don't get output
// in the logic below.
EpilogInstrs.clear();
7 changes: 6 additions & 1 deletion trunk/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -3,7 +3,7 @@

pkgname=('llvm' 'llvm-libs' 'llvm-ocaml')
pkgver=8.0.0
pkgrel=1
pkgrel=2
_ocaml_ver=4.07.1
arch=('x86_64')
url="https://llvm.org/"
Expand All @@ -13,16 +13,21 @@ makedepends=('cmake' 'ninja' 'libffi' 'libedit' 'ncurses' 'libxml2'
'python-sphinx' 'python-recommonmark')
options=('staticlibs')
source=(https://releases.llvm.org/$pkgver/llvm-$pkgver.src.tar.xz{,.sig}
0001-Fix-the-buildbot-issue-introduced-by-r351421.patch
llvm-config.h)
sha256sums=('8872be1b12c61450cacc82b3d153eab02be2546ef34fa3580ed14137bb26224c'
'SKIP'
'9b519940a1f8e18df54128c00eeb22528b3c449a9cd1320c0959cdb74ea72d16'
'597dc5968c695bbdbb0eac9e8eb5117fcd2773bc91edf5ec103ecffffab8bc48')
validpgpkeys+=('B6C8F98282B944E3B0D5C2530FC3042E345AD05D') # Hans Wennborg <hans@chromium.org>
validpgpkeys+=('474E22316ABF4785A88C6E8EA2C794A986419D8A') # Tom Stellard <tstellar@redhat.com>

prepare() {
cd "$srcdir/llvm-$pkgver.src"
mkdir build

# Fix a test failure in CodeGen/AArch64/wineh4.mir
patch -Np1 -i ../0001-Fix-the-buildbot-issue-introduced-by-r351421.patch
}

build() {
Expand Down

0 comments on commit 283d6ab

Please sign in to comment.