Skip to content

Commit

Permalink
fix(tests): Fix tests and remove JSPM jquery
Browse files Browse the repository at this point in the history
This removes the JSPM jquery dependency and installs jQuery, used for DOM based Unit Tests, as a npm devDependency. Also the Unit Tests are fixed to respect the new Animator name
  • Loading branch information
zewa666 committed Mar 19, 2015
1 parent 19f4f74 commit 22fe4de
Show file tree
Hide file tree
Showing 4 changed files with 5 additions and 7 deletions.
1 change: 0 additions & 1 deletion config.js
Original file line number Diff line number Diff line change
Expand Up @@ -10,7 +10,6 @@ System.config({
System.config({
"map": {
"aurelia-templating": "github:aurelia/templating@0.8.14",
"jquery": "github:components/jquery@2.1.3",
"github:aurelia/binding@0.3.7": {
"aurelia-dependency-injection": "github:aurelia/dependency-injection@0.4.5",
"aurelia-metadata": "github:aurelia/metadata@0.3.3",
Expand Down
2 changes: 1 addition & 1 deletion karma.conf.js
Original file line number Diff line number Diff line change
Expand Up @@ -17,9 +17,9 @@ module.exports = function(config) {
loadFiles: ['src/**/*.js', 'test/**/*.js']
},


// list of files / patterns to load in the browser
files: [
'node_modules/jquery/dist/jquery.min.js',
'node_modules/karma-jasmine-jquery/',
{
pattern: 'test/fixtures/*.html',
Expand Down
4 changes: 2 additions & 2 deletions package.json
Original file line number Diff line number Diff line change
Expand Up @@ -26,8 +26,7 @@
"lib": "dist/system"
},
"dependencies": {
"aurelia-templating": "github:aurelia/templating@^0.8.14",
"jquery": "^2.1.3"
"aurelia-templating": "github:aurelia/templating@^0.8.14"
}
},
"devDependencies": {
Expand All @@ -41,6 +40,7 @@
"gulp-yuidoc": "^0.1.2",
"jasmine-core": "^2.1.3",
"jasmine-jquery": "^2.0.6",
"jquery": "^2.1.3",
"jshint-stylish": "^1.0.0",
"karma": "^0.12.28",
"karma-babel-preprocessor": "^4.0.0",
Expand Down
5 changes: 2 additions & 3 deletions test/animator.spec.js
Original file line number Diff line number Diff line change
@@ -1,12 +1,11 @@
import {Animator} from '../src/animator';
import $ from 'jquery';
import {CssAnimator} from '../src/animator';

jasmine.getFixtures().fixturesPath = 'base/test/fixtures/';

describe('animator-css', () => {
var sut;
beforeEach( () => {
sut = new Animator();
sut = new CssAnimator();
});

describe('enter animation', () => {
Expand Down

0 comments on commit 22fe4de

Please sign in to comment.