Skip to content

Commit

Permalink
R-knitr: Autospec creation for update from version 1.45 to version 1.46
Browse files Browse the repository at this point in the history
Kyle F Butts (2):
      Add support for `# %%` for chunk demarcation in `knitr::spin` (#2307)
      make spin() recognize `#|` comments as code chunks (#2320)

Lee Mendelowitz (1):
      Fix the error when kable()'s caption value is of length > 1 (#2312)

Max Schmit (1):
      add ALTER as sql statment, that is not returning anything (#2330)

Yihui Xie (53):
      start the next version
      fix #2304: shouldn't have used `return(meta)` since `meta` is not the `citation()` but `packageDescription()`
      fix rstudio/rmarkdown#2526 by reverting bebf117 since the `cairo_pdf` device has been explicitly supported in chunk_device(); now all possible `pdf()` arguments are supported, including `family`
      Disallow unbalanced chunk delimiters (#2306)
      close #1679: obtain the caption from the chunk option `tab.cap` for `kable()`
      also try the chunk option tbl.cap when tab.cap is NULL (quarto-dev/quarto-cli#7555)
      tweak R Markdown v1 vignettes
      move mailing list link and use https in ref card
      move css and js to jsdelivr for html_vignette
      use jsdelivr for the Rhtml template
      rewrite the docco classic style using JS instead of R
      standardize the docco linear format
      new version of funmediation is on CRAN now
      support the ... argument in chunk hooks
      optimize PNG images in package vignettes via optipng and pngquant if they are installed
      use R Markdown v1 for the knitr-intro vignette, too
      delete some files that are no longer needed in inst/examples and also ignore some files
      fix #2308: don't trim trailing spaces escaped by `\`
      support in-body chunk options for ojs and mermaid (quarto-dev/quarto-cli#7799)
      amend 3dcfac4780accc3791855b298a556297f62dc73d to fix quarto-dev/quarto-cli#5994: add YAML options to code for dot/mermaid/ojs chunks so that the full chunk content can be returned to Quarto
      add trailing slashes to URLs
      use the `assert(fact, {})` syntax for all tests
      revert c9473ad: map the chunk option `tbl-cap` to `tab.cap`
      leave tbl.cap alone; don't convert it to tab.cap, since Quarto has its own special handling of `tbl-cap`
      Create FUNDING.yml
      use xfun::decimal_dot() to ensure dot as the decimal separator
      fix rstudio/rmarkdown#2525: ensure the dot is used as the decimal separator even when options(OutDec) is not `.` or `LC_NUMERIC` is inappropriate
      factor out code to xfun::csv_options() and xfun::divide_chunk()
      get_option_comment() has been moved to xfun
      roxygenize
      bump xfun version
      xfun 0.42 is on CRAN now
      revert 87d094a6c593c31a3667821865e91b4a530018ec per request from CRAN maintainers, since _R_CHECK_VIGNETTES_SKIP_RUN_MAYBE_=true has been made the default
      fix rstudio/tinytex#435: adjust PATH temporarily for pdf_crop() to be able to find the command `pdfcrop` from TinyTeX
      RStudio IDE still calls parse_params(): https://github.com/rstudio/rstudio/blob/9a6196233d8eae5aa365b73eaafba04f7714190c/src/cpp/session/modules/SessionRmdNotebook.R#L666
      a follow-up on #2331: use xfun::fenced_block() from yihui/xfun@22a97ce
      xfun 0.43 is on CRAN now
      not sure what's wrong with pak
      `knitr::imgur_upload()` is now simply a wrapper function of `xfun::upload_imgur()` (#2325)
      too many ways to do the same thing... drop support for `#-` in spin()
      make spin() work again with input that can't be parsed as R code
      use xfun::check_old_package()
      markdown no longer sets this option internally, so no need to empty it now
      better detection of Rmd v2 input in knit2html(), so it no longer warns against documents that use markdown:: or litedown:: output formats
      make regex a little stricter so it won't match rmarkdown::
      the loo issue has been fixed (#2306)
      roxygen2 requires _PACKAGE now
      rename class names 'block' to 'knitr_block', and 'inline' to 'knitr_inline' since I need to export the print() methods and the names 'block' and 'inline' are too general
      preserve trailing \n in source code by doubling it, because later we will remove trailing \n in fenced_block()
      a temporary workaround for davidgohel/flextable#621
      StructFDR has been updated on CRAN but unfortunately the maintainer didn't seem to have seen my email about #2306
      I can't use knitr_block/knitr_inline as class names since it would break the lightparser package; let me just get rid of these S3 methods, which are unnecessarily advanced---just use normal functions instead (i.e., use inherits() to do the dispatch by myself)
      CRAN release v1.46

knokknok (1):
      fix #2318: faster processing of dependencies in dep_auto() (#2321)
  • Loading branch information
fenrus75 authored and clrpackages committed Apr 9, 2024
1 parent f691e27 commit 66cbd90
Show file tree
Hide file tree
Showing 5 changed files with 29 additions and 32 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := R-knitr
URL = https://cran.r-project.org/src/contrib/knitr_1.45.tar.gz
URL = https://cran.r-project.org/src/contrib/knitr_1.46.tar.gz
ARCHIVES =

include ../common/Makefile.common
49 changes: 21 additions & 28 deletions R-knitr.spec
Original file line number Diff line number Diff line change
Expand Up @@ -2,14 +2,14 @@
# This file is auto-generated. DO NOT EDIT
# Generated by: autospec.py
# Using build pattern: R
# autospec version: v2
# autospec commit: 250a666
# autospec version: v7
# autospec commit: f56f1fa
#
Name : R-knitr
Version : 1.45
Release : 128
URL : https://cran.r-project.org/src/contrib/knitr_1.45.tar.gz
Source0 : https://cran.r-project.org/src/contrib/knitr_1.45.tar.gz
Version : 1.46
Release : 129
URL : https://cran.r-project.org/src/contrib/knitr_1.46.tar.gz
Source0 : https://cran.r-project.org/src/contrib/knitr_1.46.tar.gz
Summary : A General-Purpose Package for Dynamic Report Generation in R
Group : Development/Tools
License : GPL-2.0
Expand All @@ -35,16 +35,19 @@ Literate Programming techniques.
pushd ..
cp -a knitr buildavx2
popd
pushd ..
cp -a knitr buildavx512
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1698684911
export SOURCE_DATE_EPOCH=1712454423

%install
export SOURCE_DATE_EPOCH=1698684911
export SOURCE_DATE_EPOCH=1712454423
rm -rf %{buildroot}
LANG=C.UTF-8
CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -O3 -flto -fno-semantic-interposition "
Expand All @@ -55,26 +58,26 @@ AR=gcc-ar
RANLIB=gcc-ranlib
LDFLAGS="$CLEAR_INTERMEDIATE_LDFLAGS -Wl,-z -Wl,relro"
mkdir -p %{buildroot}/usr/lib64/R/library
mkdir -p %{buildroot}-v3/usr/lib64/R/library
mkdir -p %{buildroot}-v4/usr/lib64/R/library
mkdir -p %{buildroot}-va/usr/lib64/R/library

mkdir -p ~/.R
mkdir -p ~/.stash
echo "CFLAGS = $CFLAGS -march=x86-64-v3 -ftree-vectorize -mno-vzeroupper" > ~/.R/Makevars
echo "FFLAGS = $FFLAGS -march=x86-64-v3 -ftree-vectorize -mno-vzeroupper " >> ~/.R/Makevars
echo "CXXFLAGS = $CXXFLAGS -march=x86-64-v3 -ftree-vectorize -mno-vzeroupper " >> ~/.R/Makevars
R CMD INSTALL --install-tests --use-LTO --built-timestamp=${SOURCE_DATE_EPOCH} --data-compress=none --compress=none --build -l %{buildroot}/usr/lib64/R/library .
for i in `find %{buildroot}/usr/lib64/R/ -name "*.so"`; do mv $i $i.avx2 ; mv $i.avx2 ~/.stash/; done
echo "CFLAGS = $CFLAGS -march=x86-64-v4 -ftree-vectorize -mno-vzeroupper -mprefer-vector-width=512 " > ~/.R/Makevars
echo "FFLAGS = $FFLAGS -march=x86-64-v4 -ftree-vectorize -mno-vzeroupper -mprefer-vector-width=512 " >> ~/.R/Makevars
echo "CXXFLAGS = $CXXFLAGS -march=x86-64-v4 -ftree-vectorize -mno-vzeroupper -mprefer-vector-width=512 " >> ~/.R/Makevars
R CMD INSTALL --preclean --install-tests --use-LTO --no-test-load --data-compress=none --compress=none --built-timestamp=${SOURCE_DATE_EPOCH} --build -l %{buildroot}/usr/lib64/R/library .
for i in `find %{buildroot}/usr/lib64/R/ -name "*.so"`; do mv $i $i.avx512 ; mv $i.avx512 ~/.stash/; done
R CMD INSTALL --install-tests --use-LTO --built-timestamp=${SOURCE_DATE_EPOCH} --data-compress=none --compress=none --build -l %{buildroot}-v3/usr/lib64/R/library .
echo "CFLAGS = $CFLAGS -march=x86-64-v4 -mprefer-vector-width=512 -ftree-vectorize -mno-vzeroupper " > ~/.R/Makevars
echo "FFLAGS = $FFLAGS -march=x86-64-v4 -mprefer-vector-width=512 -ftree-vectorize -mno-vzeroupper " >> ~/.R/Makevars
echo "CXXFLAGS = $CXXFLAGS -march=x86-64-v4 -mprefer-vector-width=512 -ftree-vectorize -mno-vzeroupper " >> ~/.R/Makevars
R CMD INSTALL --preclean --install-tests --use-LTO --no-test-load --data-compress=none --compress=none --built-timestamp=${SOURCE_DATE_EPOCH} --build -l %{buildroot}-v4/usr/lib64/R/library .
echo "CFLAGS = $CFLAGS -ftree-vectorize " > ~/.R/Makevars
echo "FFLAGS = $FFLAGS -ftree-vectorize " >> ~/.R/Makevars
echo "CXXFLAGS = $CXXFLAGS -ftree-vectorize " >> ~/.R/Makevars
R CMD INSTALL --preclean --use-LTO --install-tests --data-compress=none --compress=none --built-timestamp=${SOURCE_DATE_EPOCH} --build -l %{buildroot}/usr/lib64/R/library .
cp ~/.stash/* %{buildroot}/usr/lib64/R/library/*/libs/ || :
R CMD INSTALL --preclean --use-LTO --install-tests --data-compress=none --compress=none --built-timestamp=${SOURCE_DATE_EPOCH} --build -l %{buildroot}/usr/lib64/R/library .
%{__rm} -rf %{buildroot}%{_datadir}/R/library/R.css
/usr/bin/elf-move.py avx2 %{buildroot}-v3 %{buildroot} %{buildroot}/usr/share/clear/filemap/filemap-%{name}
/usr/bin/elf-move.py avx512 %{buildroot}-v4 %{buildroot} %{buildroot}/usr/share/clear/filemap/filemap-%{name}

%files
%defattr(-,root,root,-)
Expand Down Expand Up @@ -125,7 +128,6 @@ cp ~/.stash/* %{buildroot}/usr/lib64/R/library/*/libs/ || :
/usr/lib64/R/library/knitr/doc/knitr-refcard.Rmd
/usr/lib64/R/library/knitr/doc/knitr-refcard.pdf
/usr/lib64/R/library/knitr/examples/README.md
/usr/lib64/R/library/knitr/examples/Sweavel.sty
/usr/lib64/R/library/knitr/examples/child/knitr-child-a.Rnw
/usr/lib64/R/library/knitr/examples/child/knitr-child-b.Rnw
/usr/lib64/R/library/knitr/examples/child/knitr-child.Rmd
Expand All @@ -134,7 +136,6 @@ cp ~/.stash/* %{buildroot}/usr/lib64/R/library/*/libs/ || :
/usr/lib64/R/library/knitr/examples/child/knitr-main.Rnw
/usr/lib64/R/library/knitr/examples/child/knitr-parent.Rnw
/usr/lib64/R/library/knitr/examples/child/sub/knitr-child-c.Rnw
/usr/lib64/R/library/knitr/examples/download_count.csv
/usr/lib64/R/library/knitr/examples/knit-all.R
/usr/lib64/R/library/knitr/examples/knitr-beamer.Rnw
/usr/lib64/R/library/knitr/examples/knitr-beamer.lyx
Expand All @@ -146,24 +147,20 @@ cp ~/.stash/* %{buildroot}/usr/lib64/R/library/*/libs/ || :
/usr/lib64/R/library/knitr/examples/knitr-listings.Rnw
/usr/lib64/R/library/knitr/examples/knitr-listings.lyx
/usr/lib64/R/library/knitr/examples/knitr-manual.Rnw
/usr/lib64/R/library/knitr/examples/knitr-manual.bib
/usr/lib64/R/library/knitr/examples/knitr-manual.lyx
/usr/lib64/R/library/knitr/examples/knitr-minimal.Rmd
/usr/lib64/R/library/knitr/examples/knitr-minimal.Rnw
/usr/lib64/R/library/knitr/examples/knitr-minimal.Rrst
/usr/lib64/R/library/knitr/examples/knitr-minimal.brew
/usr/lib64/R/library/knitr/examples/knitr-minimal.lyx
/usr/lib64/R/library/knitr/examples/knitr-packages.bib
/usr/lib64/R/library/knitr/examples/knitr-spin.R
/usr/lib64/R/library/knitr/examples/knitr-spin.Rmd
/usr/lib64/R/library/knitr/examples/knitr-spin.html
/usr/lib64/R/library/knitr/examples/knitr-subfloats.Rnw
/usr/lib64/R/library/knitr/examples/knitr-subfloats.lyx
/usr/lib64/R/library/knitr/examples/knitr-themes.Rnw
/usr/lib64/R/library/knitr/examples/knitr-themes.lyx
/usr/lib64/R/library/knitr/examples/knitr-twocolumn.Rnw
/usr/lib64/R/library/knitr/examples/knitr-twocolumn.lyx
/usr/lib64/R/library/knitr/examples/upload-github.R
/usr/lib64/R/library/knitr/help/AnIndex
/usr/lib64/R/library/knitr/help/aliases.rds
/usr/lib64/R/library/knitr/help/knitr.rdb
Expand All @@ -173,10 +170,6 @@ cp ~/.stash/* %{buildroot}/usr/lib64/R/library/*/libs/ || :
/usr/lib64/R/library/knitr/html/R.css
/usr/lib64/R/library/knitr/misc/R.css
/usr/lib64/R/library/knitr/misc/Sweavel.sty
/usr/lib64/R/library/knitr/misc/datatables.html
/usr/lib64/R/library/knitr/misc/docco-classic.css
/usr/lib64/R/library/knitr/misc/docco-classic.html
/usr/lib64/R/library/knitr/misc/docco-template.html
/usr/lib64/R/library/knitr/misc/gWidgetsWWW2-knitr.R
/usr/lib64/R/library/knitr/misc/knitr-template.Rhtml
/usr/lib64/R/library/knitr/misc/knitr-template.Rmd
Expand Down
6 changes: 5 additions & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = R-knitr
url = https://cran.r-project.org/src/contrib/knitr_1.45.tar.gz
url = https://cran.r-project.org/src/contrib/knitr_1.46.tar.gz
archives =
giturl = https://github.com/yihui/knitr.git
domain =
Expand All @@ -9,6 +9,8 @@ alias =
[autospec]
# build 32 bit libraries
32bit = false
# allow windows executables (*.exe, *.dll) to be packaged
allow_exe = false
# allow package to build with test failures
allow_test_failures = true
# unset %build ld_as_needed variable
Expand Down Expand Up @@ -59,6 +61,8 @@ server = false
skip_tests = true
# add .so files to the lib package instead of dev
so_to_lib = false
# configure build for apx
use_apx = false
# configure build for avx2
use_avx2 = true
# configure build for avx512
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
128
129
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
8b3673f38ea9c6309cb696b770c98387eaa5ea25/knitr_1.45.tar.gz
4f6f7310017e4a525b18e7386e459e742381bb44/knitr_1.46.tar.gz

0 comments on commit 66cbd90

Please sign in to comment.