Skip to content

Commit

Permalink
pypi-importlib_metadata: Autospec creation for update from version 8.…
Browse files Browse the repository at this point in the history
…4.0 to version 8.5.0

Anderson Bravalheri (1):
      Add `--fix`  flag to ruff pre-commit hook for automatic suggestion of fixes (jaraco/skeleton#140)

Avasam (4):
      Add Protocols, remove @overload, from `.coveragerc` `exclude_also` (jaraco/skeleton#135)
      Loosen restrictions on mypy (jaraco/skeleton#136)
      Pass mypy and link issues
      Update tests/_path.py with jaraco.path 3.7.2

Daniel Hollas (3):
      Defer import of zipp
      Defer json import
      Defer platform import

Dimitri Papadopoulos Orfanos (1):
      Update to the latest ruff version (jaraco/skeleton#137)

Jason R. Coombs (24):
      Split the test dependencies into four classes (test, cover, type, check). (jaraco/skeleton#139)
      👹 Feed the hobgoblins (delint).
      Remove superfluous parentheses.
      Rely on zipp overlay for zipfile.Path.
      Add upstream and local sections for 'type' extra, since many projects will have 'types-*' dependencies.
      🧎‍♀️ Genuflect to the types.
      🧎‍♀️ Genuflect to the types.
      🧎‍♀️ Genuflect to the types.
      🧎‍♀️ Genuflect to the types.
      🧎‍♀️ Genuflect to the types.
      🧎‍♀️ Genuflect to the types.
      Add reference to development methodology.
      Disable mypy for now. Ref jaraco/skeleton#143
      Move overload-overlap disablement to its own line for easier diffs and simpler relevant comments.
      Add a degenerate nitpick_ignore for downstream consumers. Add a 'local' comment to delineate where the skeleton ends and the downstream begins.
      Add support for linking usernames.
      Include the trailing slash in disable_error_code(overload-overlap), also required for clean diffs.
      Add comment to protect the deferred import.
      Add news fragment.
      Revert "Defer platform import"
      Add comment to protect the deferred import.
      Add news fragment.
      Back out changes to tests._path
      Finalize
  • Loading branch information
fenrus75 committed Sep 11, 2024
1 parent c0a6a36 commit b202e73
Show file tree
Hide file tree
Showing 5 changed files with 13 additions and 13 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-importlib_metadata
URL = https://files.pythonhosted.org/packages/c0/bd/fa8ce65b0a7d4b6d143ec23b0f5fd3f7ab80121078c465bc02baeaab22dc/importlib_metadata-8.4.0.tar.gz
URL = https://files.pythonhosted.org/packages/cd/12/33e59336dca5be0c398a7482335911a33aa0e20776128f038019f1a95f1b/importlib_metadata-8.5.0.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-importlib_metadata
url = https://files.pythonhosted.org/packages/c0/bd/fa8ce65b0a7d4b6d143ec23b0f5fd3f7ab80121078c465bc02baeaab22dc/importlib_metadata-8.4.0.tar.gz
url = https://files.pythonhosted.org/packages/cd/12/33e59336dca5be0c398a7482335911a33aa0e20776128f038019f1a95f1b/importlib_metadata-8.5.0.tar.gz
archives =
giturl = https://github.com/python/importlib_metadata/
domain =
Expand Down
18 changes: 9 additions & 9 deletions pypi-importlib_metadata.spec
Original file line number Diff line number Diff line change
Expand Up @@ -2,14 +2,14 @@
# This file is auto-generated. DO NOT EDIT
# Generated by: autospec.py
# Using build pattern: pyproject
# autospec version: v18
# autospec version: v19
# autospec commit: f35655a
#
Name : pypi-importlib_metadata
Version : 8.4.0
Release : 121
URL : https://files.pythonhosted.org/packages/c0/bd/fa8ce65b0a7d4b6d143ec23b0f5fd3f7ab80121078c465bc02baeaab22dc/importlib_metadata-8.4.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/c0/bd/fa8ce65b0a7d4b6d143ec23b0f5fd3f7ab80121078c465bc02baeaab22dc/importlib_metadata-8.4.0.tar.gz
Version : 8.5.0
Release : 122
URL : https://files.pythonhosted.org/packages/cd/12/33e59336dca5be0c398a7482335911a33aa0e20776128f038019f1a95f1b/importlib_metadata-8.5.0.tar.gz
Source0 : https://files.pythonhosted.org/packages/cd/12/33e59336dca5be0c398a7482335911a33aa0e20776128f038019f1a95f1b/importlib_metadata-8.5.0.tar.gz
Summary : Read metadata from Python packages
Group : Development/Tools
License : Apache-2.0
Expand Down Expand Up @@ -62,18 +62,18 @@ python3 components for the pypi-importlib_metadata package.


%prep
%setup -q -n importlib_metadata-8.4.0
cd %{_builddir}/importlib_metadata-8.4.0
%setup -q -n importlib_metadata-8.5.0
cd %{_builddir}/importlib_metadata-8.5.0
pushd ..
cp -a importlib_metadata-8.4.0 buildavx2
cp -a importlib_metadata-8.5.0 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1724201285
export SOURCE_DATE_EPOCH=1726087141
export GCC_IGNORE_WERROR=1
CLEAR_INTERMEDIATE_CFLAGS="$CLEAR_INTERMEDIATE_CFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
CLEAR_INTERMEDIATE_FCFLAGS="$CLEAR_INTERMEDIATE_FFLAGS -fdebug-types-section -femit-struct-debug-baseonly -fno-lto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
121
122
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
ea159a3096e404449886168c8358afba9404ca6a/importlib_metadata-8.4.0.tar.gz
99cf37cc799525633a0956a7b14951f93ddf29fe/importlib_metadata-8.5.0.tar.gz

0 comments on commit b202e73

Please sign in to comment.