Skip to content

Commit

Permalink
pypi-pydantic: Autospec creation for update from version 2.0.1 to ver…
Browse files Browse the repository at this point in the history
…sion 1.10.10

Adrian Garcia Badaracco (1):
      Support for email-validator>=2.0.0.post2 (#5627)

Amin Alaee (1):
      Remove pkg_resources test (#5508)

Arseny Boykov (1):
      [1.10.x] Properly encode model and dataclass default for schema (#4781)

Bas Schoenmaeckers (1):
      Add future and past date hypothesis strategies (#5850)

Benoit C. Sirois (1):
      Fixes discriminated unions not working on aliased literal fields. Issue #3849. (#5736)

David Montague (7):
      Disable Google analytics (#5059)
      prepare for v1.10.6 (#5157)
      Fix mypy plugin misbehavior with from_orm for user classes (#5193)
      Mypy plugin: Add implicit defaults for Field with no default argument (#5207)
      Fix mypy plugin crash (1.10.X-fixes) (#5208)
      prepare for 1.10.7 (#5248)
      Fix internal error with mypy (#5449)

Dimitri Papadopoulos Orfanos (1):
      Fix typos found by codespell (#5375)

Eric Jolibois (3):
      fix: support assignment on DataclassProxy (#4880)
      fix: avoid multiple calls of `__post_init__` when dataclasses are inherited (#4493)
      fix: use dataclasses proxy for frozen or empty dataclasses (#4878)

Gulu Mammadli (1):
      fix: Fix broken link in the docs (Pydantic Models - Data Binding) (#5074)

Hasan Ramezani (11):
      fix: missing file extension in model_config.md link (#4512) (#4513)
      Update mkdocs.yml (#4524) (#4532)
      v2 docs broken link fix (#4533) (#4550)
      Replace deprecated `get_event_loop` with `asyncio.run` (#4859) (#4860)
      Fix Literal bug with typing-extension==4.6.0 (#5826)
      Prepare for 1.10.8 (#5830)
      Add Pydantic classifier (#5847)
      [Backport] Fix Decimal trailing zero handling (#5968)
      Prepare for 1.10.9 (#6034)
      Add Pydantic `Json` field support to settings management (#6250)
      Prepare for 1.10.10 (#6308)

Jens Heinrich (4):
      Fix wrong type for parameter (#5127)
      Mark optional params as Optional (#5128)
      Use getattr and default for qualname (#5126)
      tweak type annotations (#5499)

Jon Parise (1):
      Allow dicts to have both patternProperties and additionalProperties (#4641)

K900 (1):
      Fix racy doctests (#6103)

Kurt McKee (1):
      Raise `ValidationError` for unhashable discriminator values (#5132)

Kyle Finley (1):
      update `AnyClassMethod` for change in python/typeshed#9771 (#5505)

Marc Mueller (3):
      [cherry-pick] Fix mypy plugin for 1.1.0 (#5077) (#5111)
      Don't apply dataclass transform twice with plugin + mypy 1.1.1 (#5162)
      [cherry-pick] Fix mypy plugin for 1.4.0 (#5927) (#5928)

Marcelo Trylesinski (1):
      ✅ Update FastAPI test script (#6117)

Markus Scheidgen (1):
      Fixed literal validator errors for unhashable values (#6194)

MarkusSintonen (1):
      fix: Fix broken parametrized bases with GenericModels (#5052)

Matt Fulgo (2):
      Allows Optional lists with unique_items check (#4568)
      Fix TypeError for GenericModel with Callable param (#4653)

Mòrian (1):
      Add postgresql+psycopg as allowed scheme for PostgreDsn (#4689) (#4690)

Samuel Colvin (26):
      test on the 1.10.X-fixes branch
      fix copy_on_model_validation type hint (#4491)
      use "field_specifiers", fix #4500 (#4501)
      add hooky config
      uprev 3.11, add check job (#4662)
      Add Jina AI to sponsors (#4767)
      bust CI cache, fix docs-build
      bust CI test cache (#4786)
      Moving docs to `docs.pydantic.dev` (#4818)
      Reduce binary sizes (#4862)
      fix history links (#4866)
      prepare for v1.10.3, fix #4552
      Typing extensions min version (#4886)
      prepare for v1.10.4 release
      add dependencies-check to 1.10.X-fixes
      fix install step for dependencies check
      fix coverage badge to use correct branch (#5060)
      prepare for v1.10.5
      Announcement (#5069)
      [ALPHA] V2 Alpha Blog Post (#5343)
      fix link in alpha release to v2 blog
      Add mike to V1 docs (#5628)
      enable fastapi testing on 1.10 (#5635)
      V1 add `build-docs.sh` (#5832)
      remove sponsors from docs (#5833)
      add roadmap to announcement (#6120)

Serge Matveenko (1):
      📌 Use Cython < v3 (#5845)

Sigurd Spieckermann (1):
      [1.10.X] Fix field regex with StrictStr type annotation (#4538)

Simon Matejetz (1):
      Fix creating schema from model using ConstrainedStr with regex str as dict key (#5223)

Slava (1):
      Handle X | Y union in GenericModel (#4977)

Volker Hilsenstein (1):
      Fix broken cross-references (#4743)

github-actions[bot] (12):
      Fix "trough" typo in Model Config docs (#4593) (#4594)
      Add missing typing to example (#4596) (#4605)
      Fix improper parsing of Enum document (#4736)
      Renaming BaseModel (#4766)
      fix typo in docs (#4765)
      Remove trailing "```" (#4799) (#4800)
      Add newline before `Outputs:` when printing json output in docs (#4802) (#4848)
      Fix typo in types usage documentation. (#4825) (#4849)
      fixed documentation typo (#4855) (#4858)
      Fixed datetime format specifier in docs (#4876) (#4879)
      Fix typo in Field function docstring (#4931) (#4932)
      Invalidate mypy cache if config changes (#5007) (#5023)

gou177 (1):
      fix: Parsing of custom root models (#4883) (#4884)

javibookline (1):
      Discriminated union literal enum values (#5188)

kgolawski (1):
      Fix code typo in docs (#4775)

mark-todd (1):
      Bug fix for forward refs in generics (#6157)

mbillingr (1):
      Dataclass deepcopy 1.10 (#4963)

⬢ Samuel Colvin (3):
      remove remains of ads, add custom analytics (#4927)
      simplify analytics more (#4930)
      uprev mkdocs-material, fix maxcdn errors (#4954)
  • Loading branch information
fenrus75 committed Jul 5, 2023
1 parent 4f7047f commit 357c58b
Show file tree
Hide file tree
Showing 5 changed files with 23 additions and 24 deletions.
2 changes: 1 addition & 1 deletion Makefile
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
PKG_NAME := pypi-pydantic
URL = https://files.pythonhosted.org/packages/ee/f6/e6f0c9bcb402c1817438491f2ce7480f4f3c179c6e51db13ba8941e94c49/pydantic-2.0.1.tar.gz
URL = https://files.pythonhosted.org/packages/eb/84/9b0a0e2d931fc9bdb32e6905076714f9592f9b20de03c90fd0f65b3ab063/pydantic-1.10.10.tar.gz
ARCHIVES =

include ../common/Makefile.common
2 changes: 1 addition & 1 deletion options.conf
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
[package]
name = pypi-pydantic
url = https://files.pythonhosted.org/packages/ee/f6/e6f0c9bcb402c1817438491f2ce7480f4f3c179c6e51db13ba8941e94c49/pydantic-2.0.1.tar.gz
url = https://files.pythonhosted.org/packages/eb/84/9b0a0e2d931fc9bdb32e6905076714f9592f9b20de03c90fd0f65b3ab063/pydantic-1.10.10.tar.gz
archives =
giturl = https://github.com/samuelcolvin/pydantic/
domain =
Expand Down
39 changes: 19 additions & 20 deletions pypi-pydantic.spec
Original file line number Diff line number Diff line change
@@ -1,30 +1,29 @@
#
# This file is auto-generated. DO NOT EDIT
# Generated by: autospec.py
# Using build pattern: pyproject
# Using build pattern: distutils3
#
Name : pypi-pydantic
Version : 2.0.1
Release : 21
URL : https://files.pythonhosted.org/packages/ee/f6/e6f0c9bcb402c1817438491f2ce7480f4f3c179c6e51db13ba8941e94c49/pydantic-2.0.1.tar.gz
Source0 : https://files.pythonhosted.org/packages/ee/f6/e6f0c9bcb402c1817438491f2ce7480f4f3c179c6e51db13ba8941e94c49/pydantic-2.0.1.tar.gz
Version : 1.10.10
Release : 22
URL : https://files.pythonhosted.org/packages/eb/84/9b0a0e2d931fc9bdb32e6905076714f9592f9b20de03c90fd0f65b3ab063/pydantic-1.10.10.tar.gz
Source0 : https://files.pythonhosted.org/packages/eb/84/9b0a0e2d931fc9bdb32e6905076714f9592f9b20de03c90fd0f65b3ab063/pydantic-1.10.10.tar.gz
Summary : Data validation using Python type hints
Group : Development/Tools
License : MIT
Requires: pypi-pydantic-license = %{version}-%{release}
Requires: pypi-pydantic-python = %{version}-%{release}
Requires: pypi-pydantic-python3 = %{version}-%{release}
BuildRequires : buildreq-distutils3
BuildRequires : pypi(hatch_fancy_pypi_readme)
BuildRequires : pypi(hatchling)
BuildRequires : pypi(typing_extensions)
# Suppress stripping binaries
%define __strip /bin/true
%define debug_package %{nil}

%description
# Pydantic
# pydantic
[![CI](https://github.com/pydantic/pydantic/workflows/CI/badge.svg?event=push)](https://github.com/pydantic/pydantic/actions?query=event%3Apush+branch%3Amain+workflow%3ACI)
[![Coverage](https://coverage-badge.samuelcolvin.workers.dev/pydantic/pydantic.svg)](https://coverage-badge.samuelcolvin.workers.dev/redirect/pydantic/pydantic)
[![Coverage](https://coverage-badge.samuelcolvin.workers.dev/pydantic/pydantic.svg?branch=1.10.X-fixes)](https://coverage-badge.samuelcolvin.workers.dev/redirect/pydantic/pydantic?branch=1.10.X-fixes)
[![pypi](https://img.shields.io/pypi/v/pydantic.svg)](https://pypi.python.org/pypi/pydantic)
[![CondaForge](https://img.shields.io/conda/v/conda-forge/pydantic.svg)](https://anaconda.org/conda-forge/pydantic)
[![downloads](https://pepy.tech/badge/pydantic/month)](https://pepy.tech/project/pydantic)
Expand Down Expand Up @@ -62,18 +61,18 @@ python3 components for the pypi-pydantic package.


%prep
%setup -q -n pydantic-2.0.1
cd %{_builddir}/pydantic-2.0.1
%setup -q -n pydantic-1.10.10
cd %{_builddir}/pydantic-1.10.10
pushd ..
cp -a pydantic-2.0.1 buildavx2
cp -a pydantic-1.10.10 buildavx2
popd

%build
export http_proxy=http://127.0.0.1:9/
export https_proxy=http://127.0.0.1:9/
export no_proxy=localhost,127.0.0.1,0.0.0.0
export LANG=C.UTF-8
export SOURCE_DATE_EPOCH=1688572762
export SOURCE_DATE_EPOCH=1688574831
export GCC_IGNORE_WERROR=1
export AR=gcc-ar
export RANLIB=gcc-ranlib
Expand All @@ -83,23 +82,23 @@ export FCFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -
export FFLAGS="$FFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
export CXXFLAGS="$CXXFLAGS -O3 -fdebug-types-section -femit-struct-debug-baseonly -ffat-lto-objects -flto=auto -g1 -gno-column-info -gno-variable-location-views -gz=zstd "
export MAKEFLAGS=%{?_smp_mflags}
python3 -m build --wheel --skip-dependency-check --no-isolation
python3 setup.py build

pushd ../buildavx2/
export CFLAGS="$CFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
python3 -m build --wheel --skip-dependency-check --no-isolation
python3 setup.py build

popd

%install
export MAKEFLAGS=%{?_smp_mflags}
rm -rf %{buildroot}
mkdir -p %{buildroot}/usr/share/package-licenses/pypi-pydantic
cp %{_builddir}/pydantic-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pydantic/cb7f5ccd3d8ef51b9fe19181d2ac801cc59231a4 || :
pip install --root=%{buildroot} --no-deps --ignore-installed dist/*.whl
cp %{_builddir}/pydantic-%{version}/LICENSE %{buildroot}/usr/share/package-licenses/pypi-pydantic/f66e0df7b6d8feb97cd45e4fd362d9d412c774b2 || :
python3 -tt setup.py build install --root=%{buildroot}
echo ----[ mark ]----
cat %{buildroot}/usr/lib/python3*/site-packages/*/requires.txt || :
echo ----[ mark ]----
Expand All @@ -109,7 +108,7 @@ export CXXFLAGS="$CXXFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FFLAGS="$FFLAGS -m64 -march=x86-64-v3 -Wl,-z,x86-64-v3 "
export FCFLAGS="$FCFLAGS -m64 -march=x86-64-v3 "
export LDFLAGS="$LDFLAGS -m64 -march=x86-64-v3 "
pip install --root=%{buildroot}-v3 --no-deps --ignore-installed dist/*.whl
python3 -tt setup.py build install --root=%{buildroot}-v3
popd
/usr/bin/elf-move.py avx2 %{buildroot}-v3 %{buildroot} %{buildroot}/usr/share/clear/filemap/filemap-%{name}

Expand All @@ -118,7 +117,7 @@ popd

%files license
%defattr(0644,root,root,0755)
/usr/share/package-licenses/pypi-pydantic/cb7f5ccd3d8ef51b9fe19181d2ac801cc59231a4
/usr/share/package-licenses/pypi-pydantic/f66e0df7b6d8feb97cd45e4fd362d9d412c774b2

%files python
%defattr(-,root,root,-)
Expand Down
2 changes: 1 addition & 1 deletion release
Original file line number Diff line number Diff line change
@@ -1 +1 @@
21
22
2 changes: 1 addition & 1 deletion upstream
Original file line number Diff line number Diff line change
@@ -1 +1 @@
81ca3f594c04821ea464ee6df6e3c972a5e146e9/pydantic-2.0.1.tar.gz
8a9e4c6ff238f2fd84a016785c5130d9b4b4a28d/pydantic-1.10.10.tar.gz

0 comments on commit 357c58b

Please sign in to comment.