Skip to content

Commit

Permalink
updpatch: linux
Browse files Browse the repository at this point in the history
Generate symbols for dtbs to support overlays
  • Loading branch information
quininer authored and felixonmars committed Nov 23, 2024
1 parent 2e085b9 commit a1760eb
Showing 1 changed file with 13 additions and 4 deletions.
17 changes: 13 additions & 4 deletions linux/riscv64.patch
Original file line number Diff line number Diff line change
Expand Up @@ -30,7 +30,7 @@ index 71b747f..d111c9a 100644

export KBUILD_BUILD_HOST=archlinux
export KBUILD_BUILD_USER=$pkgbase
@@ -79,6 +85,12 @@ prepare() {
@@ -79,13 +85,20 @@ prepare() {
make olddefconfig
diff -u ../config .config || :

Expand All @@ -43,7 +43,16 @@ index 71b747f..d111c9a 100644
make -s kernelrelease > version
echo "Prepared $pkgbase version $(<version)"
}
@@ -126,6 +138,9 @@ _package() {

build() {
cd $_srcname
- make all
+ # Generate symbols for dtbs to support overlays
+ make DTC_FLAGS="-@" all
make -C tools/bpf/bpftool vmlinux.h feature-clang-bpf-co-re=1
make htmldocs
}
@@ -126,6 +139,9 @@ _package() {
ZSTD_CLEVEL=19 make INSTALL_MOD_PATH="$pkgdir/usr" INSTALL_MOD_STRIP=1 \
DEPMOD=/doesnt/exist modules_install # Suppress depmod

Expand All @@ -53,7 +62,7 @@ index 71b747f..d111c9a 100644
# remove build link
rm "$modulesdir"/build
}
@@ -141,20 +156,17 @@ _package-headers() {
@@ -141,20 +157,17 @@ _package-headers() {
install -Dt "$builddir" -m644 .config Makefile Module.symvers System.map \
localversion.* version vmlinux tools/bpf/bpftool/vmlinux.h
install -Dt "$builddir/kernel" -m644 kernel/Makefile
Expand All @@ -77,7 +86,7 @@ index 71b747f..d111c9a 100644

install -Dt "$builddir/drivers/md" -m644 drivers/md/*.h
install -Dt "$builddir/net/mac80211" -m644 net/mac80211/*.h
@@ -176,7 +188,7 @@ _package-headers() {
@@ -176,7 +189,7 @@ _package-headers() {
echo "Removing unneeded architectures..."
local arch
for arch in "$builddir"/arch/*/; do
Expand Down

0 comments on commit a1760eb

Please sign in to comment.