Skip to content

Commit

Permalink
Bump version to 0.54.0
Browse files Browse the repository at this point in the history
  • Loading branch information
gentoo90 committed Jan 12, 2025
1 parent 105ca7a commit 4574feb
Show file tree
Hide file tree
Showing 4 changed files with 9 additions and 5 deletions.
4 changes: 4 additions & 0 deletions CHANGELOG.md
Original file line number Diff line number Diff line change
@@ -1,5 +1,9 @@
# Changelog

## 0.54.0
* Breaking change: Migrate to the 2021 edition of Rust (MSRV 1.56)
* Breaking change: Upgrade `windows-sys` to version 0.52

## 0.15.0, 0.53.0
* Don't stop deserialization of `Any` due to `REG_NONE` (pullrequest [#67](https://github.com/gentoo90/winreg-rs/pull/67), fixes [#66](https://github.com/gentoo90/winreg-rs/issues/66))
* Implement (de)serialization of `Option` ([#56](https://github.com/gentoo90/winreg-rs/issues/56))
Expand Down
2 changes: 1 addition & 1 deletion Cargo.toml
Original file line number Diff line number Diff line change
Expand Up @@ -2,7 +2,7 @@
name = "winreg"
edition = "2021"
rust-version = "1.56"
version = "0.53.0"
version = "0.54.0"
authors = ["Igor Shaula <gentoo90@gmail.com>"]
license = "MIT"
description = "Rust bindings to MS Windows Registry API"
Expand Down
6 changes: 3 additions & 3 deletions README.md
Original file line number Diff line number Diff line change
Expand Up @@ -36,7 +36,7 @@ Current features:
```toml
# Cargo.toml
[dependencies]
winreg = "0.53"
winreg = "0.54"
```

```rust
Expand Down Expand Up @@ -138,7 +138,7 @@ fn main() -> io::Result<()> {
```toml
# Cargo.toml
[dependencies]
winreg = { version = "0.53", features = ["transactions"] }
winreg = { version = "0.54", features = ["transactions"] }
```

```rust
Expand Down Expand Up @@ -179,7 +179,7 @@ fn main() -> io::Result<()> {
```toml
# Cargo.toml
[dependencies]
winreg = { version = "0.53", features = ["serialization-serde"] }
winreg = { version = "0.54", features = ["serialization-serde"] }
serde = "1"
serde_derive = "1"
```
Expand Down
2 changes: 1 addition & 1 deletion src/lib.rs
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@
//!```toml,ignore
//!# Cargo.toml
//![dependencies]
//!winreg = "0.53"
//!winreg = "0.54"
//!```
//!
//!```no_run
Expand Down

0 comments on commit 4574feb

Please sign in to comment.