Skip to content

Commit

Permalink
CI: check Cargo.toml formatting
Browse files Browse the repository at this point in the history
  • Loading branch information
gentoo90 committed Jan 11, 2025
1 parent cb06180 commit cbaeb4e
Show file tree
Hide file tree
Showing 3 changed files with 24 additions and 2 deletions.
10 changes: 9 additions & 1 deletion .github/workflows/ci.yaml
Original file line number Diff line number Diff line change
Expand Up @@ -107,7 +107,15 @@ jobs:
with:
command: update
args: --package num-traits --precise 0.2.18
- name: Check formatting
- name: Setup Taplo
if: matrix.lint
uses: uncenter/setup-taplo@v1
with:
version: "0.8.1"
- name: Check Cargo.toml formatting
if: matrix.lint
run: taplo fmt --check --diff
- name: Check sourcecode formatting
if: matrix.lint
uses: actions-rs/cargo@v1
with:
Expand Down
4 changes: 4 additions & 0 deletions .taplo.toml
Original file line number Diff line number Diff line change
@@ -0,0 +1,4 @@
include = [".taplo.toml", "Cargo.toml"]

[formatting]
indent_string = " "
12 changes: 11 additions & 1 deletion Cargo.toml
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,17 @@ categories = ["api-bindings", "os::windows-apis"]

[dependencies]
cfg-if = "1.0"
winapi = { version = "0.3.9", features = ["impl-default", "impl-debug", "minwindef", "minwinbase", "timezoneapi", "winerror", "winnt", "winreg", "handleapi"] }
winapi = { version = "0.3.9", features = [
"impl-default",
"impl-debug",
"minwindef",
"minwinbase",
"timezoneapi",
"winerror",
"winnt",
"winreg",
"handleapi",
] }
chrono = { version = "0.4.6", optional = true }
serde = { version = "1", optional = true }

Expand Down

0 comments on commit cbaeb4e

Please sign in to comment.