forked from openwrt/packages
-
Notifications
You must be signed in to change notification settings - Fork 1
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
python,python3: remove multi-arch support, and /usr/local paths
This should hopefully reduce weird behaviour caused by the host system. Signed-off-by: Alexandru Ardelean <ardeleanalex@gmail.com>
- Loading branch information
Showing
6 changed files
with
41 additions
and
28 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
14 changes: 0 additions & 14 deletions
14
lang/python/python/patches/006-remove-debian-multiarch-support.patch
This file was deleted.
Oops, something went wrong.
18 changes: 18 additions & 0 deletions
18
lang/python/python/patches/006-remove-multi-arch-and-local-paths.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,18 @@ | ||
diff --git a/setup.py b/setup.py | ||
index 54054c2..d043761 100644 | ||
--- a/setup.py | ||
+++ b/setup.py | ||
@@ -454,13 +454,8 @@ class PyBuildExt(build_ext): | ||
os.unlink(tmpfile) | ||
|
||
def detect_modules(self): | ||
- # Ensure that /usr/local is always used | ||
- if not cross_compiling: | ||
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib') | ||
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') | ||
if cross_compiling: | ||
self.add_gcc_paths() | ||
- self.add_multiarch_paths() | ||
|
||
# Add paths specified in the environment variables LDFLAGS and | ||
# CPPFLAGS for header and library files. |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
12 changes: 0 additions & 12 deletions
12
lang/python/python3/patches/006-remove-debian-multiarch-support.patch
This file was deleted.
Oops, something went wrong.
21 changes: 21 additions & 0 deletions
21
lang/python/python3/patches/006-remove-multi-arch-and-local-paths.patch
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,21 @@ | ||
diff --git a/setup.py b/setup.py | ||
index f04bf22..01b851e 100644 | ||
--- a/setup.py | ||
+++ b/setup.py | ||
@@ -487,16 +487,9 @@ class PyBuildExt(build_ext): | ||
return ['m'] | ||
|
||
def detect_modules(self): | ||
- # Ensure that /usr/local is always used, but the local build | ||
- # directories (i.e. '.' and 'Include') must be first. See issue | ||
- # 10520. | ||
- if not cross_compiling: | ||
- add_dir_to_list(self.compiler.library_dirs, '/usr/local/lib') | ||
- add_dir_to_list(self.compiler.include_dirs, '/usr/local/include') | ||
# only change this for cross builds for 3.3, issues on Mageia | ||
if cross_compiling: | ||
self.add_gcc_paths() | ||
- self.add_multiarch_paths() | ||
|
||
# Add paths specified in the environment variables LDFLAGS and | ||
# CPPFLAGS for header and library files. |