Skip to content

Commit

Permalink
Update ruby-hashie to 3.4.0.
Browse files Browse the repository at this point in the history
## 3.4.0 (02/02/2014)

* [#271](hashie/hashie#271): Added ability to define defaults based on current hash - [@gregory](https://github.com/gregory).
* [#247](hashie/hashie#247): Fixed #stringify_keys and #symbolize_keys collision with ActiveSupport - [@bartoszkopinski](https://github.com/bartoszkopinski).
* [#249](hashie/hashie#249): SafeAssignment will now also protect hash-style assignments - [@jrochkind](https://github.com/jrochkind).
* [#251](hashie/hashie#251): Added block support to indifferent access #fetch - [@jgraichen](https://github.com/jgraichen).
* [#252](https://github.com/intridia/hashie/pull/252): Added support for conditionally required Hashie::Dash attributes - [@ccashwell](https://github.com/ccashwell).
* [#256](https://github.com/intridia/hashie/pull/256): Inherit key coercions - [@Erol](https://github.com/Erol).
* [#259](https://github.com/intridia/hashie/pull/259): Fixed handling of default proc values in Mash - [@Erol](https://github.com/Erol).
* [#260](https://github.com/intridia/hashie/pull/260): Added block support to Extensions::DeepMerge - [@Galathius](https://github.com/galathius).
* [#254](hashie/hashie#254): Added public utility methods for stringify and symbolize keys - [@maxlinc](https://github.com/maxlinc).
* [#261](hashie/hashie#261): Fixed bug where Dash.property modifies argument object - [@d_tw](https://github.com/d_tw).
* [#264](hashie/hashie#264): Methods such as abc? return true/false with Hashie::Extensions::MethodReader - [@Zloy](https://github.com/Zloy).
* [#269](hashie/hashie#269): Add #extractable_options? so ActiveSupport Array#extract_options! can extract it - [@ridiculous](https://github.com/ridiculous).
* Your contribution here.

## 3.3.2 (11/26/2014)

* [#233](hashie/hashie#233): Custom error messages for required properties in Hashie::Dash subclasses - [@Joss](https://github.com/joss).
* [#231](hashie/hashie#231): Added support for coercion on class type that inherit from Hash - [@gregory](https://github.com/gregory).
* [#228](hashie/hashie#228): Made Hashie::Extensions::Parsers::YamlErbParser pass template filename to ERB - [@jperville](https://github.com/jperville).
* [#224](hashie/hashie#224): Merging Hashie::Mash now correctly only calls the block on duplicate values - [@amysutedja](https://github.com/amysutedja).
* [#221](hashie/hashie#221): Reduce amount of allocated objects on calls with suffixes in Hashie::Mash - [@kubum](https://github.com/kubum).
* [#245](hashie/hashie#245): Added Hashie::Extensions::MethodAccessWithOverride to autoloads - [@Fritzinger](https://github.com/Fritzinger).

## 3.3.1 (8/26/2014)

* [#183](hashie/hashie#183): Added Mash#load with YAML file support - [@gregory](https://github.com/gregory).
* [#195](hashie/hashie#195): Ensure that the same object is returned after injecting IndifferentAccess - [@michaelherold](https://github.com/michaelherold).
* [#201](hashie/hashie#201): Hashie::Trash transforms can be inherited - [@FoboCasteR](https://github.com/fobocaster).
* [#189](hashie/hashie#189): Added Rash#fetch - [@medcat](https://github.com/medcat).
* [#200](hashie/hashie#200): Improved coercion: primitives and error handling - [@maxlinc](https://github.com/maxlinc).
* [#204](hashie/hashie#204): Added Hashie::Extensions::MethodOverridingWriter and Hashie::Extensions::MethodAccessWithOverride - [@michaelherold](https://github.com/michaelherold).
* [#205](http://github.com/intridea/hashie/pull/205): Added Hashie::Extensions::Mash::SafeAssignment - [@michaelherold](https://github.com/michaelherold).
* [#206](http://github.com/intridea/hashie/pull/206): Fixed stack overflow from repetitively including coercion in subclasses - [@michaelherold](https://github.com/michaelherold).
* [#207](http://github.com/intridea/hashie/pull/207): Fixed inheritance of transformations in Trash - [@FoboCasteR](https://github.com/fobocaster).
* [#209](http://github.com/intridea/hashie/pull/209): Added Hashie::Extensions::DeepFind - [@michaelherold](https://github.com/michaelherold).
* [#69](hashie/hashie#69): Fixed regression in assigning multiple properties in Hashie::Trash - [@michaelherold](https://github.com/michaelherold), [@einzige](https://github.com/einzige), [@dblock](https://github.com/dblock).

## 3.2.0 (7/10/2014)

* [#164](hashie/hashie#164), [#165](hashie/hashie#165), [#166](hashie/hashie#166): Fixed stack overflow when coercing mashes that contain ActiveSupport::HashWithIndifferentAccess values - [@numinit](https://github.com/numinit), [@kgrz](https://github.com/kgrz).
* [#177](hashie/hashie#177): Added support for coercing enumerables and collections - [@gregory](https://github.com/gregory).
* [#179](hashie/hashie#179): Mash#values_at will convert each key before doing the lookup - [@nahiluhmot](https://github.com/nahiluhmot).
* [#184](hashie/hashie#184): Allow ranges on Rash to match all Numeric types - [@medcat](https://github.com/medcat).
* [#187](hashie/hashie#187): Automatically require version - [@medcat](https://github.com/medcat).
* [#190](hashie/hashie#190): Fixed `coerce_key` with `from` Trash feature and Coercion extension - [@gregory](https://github.com/gregory).
* [#192](hashie/hashie#192): Fixed StringifyKeys#stringify_keys! to recursively stringify keys of embedded ::Hash types - [@dblock](https://github.com/dblock).

## 3.1.0 (6/25/2014)

* [#169](hashie/hashie#169): Hash#to_hash will also convert nested objects that implement to_hash - [@gregory](https://github.com/gregory).
* [#171](hashie/hashie#171): Include Trash and Dash class name when raising `NoMethodError` - [@gregory](https://github.com/gregory).
* [#172](hashie/hashie#172): Added Dash and Trash#update_attributes! - [@gregory](https://github.com/gregory).
* [#173](hashie/hashie#173): Auto include Dash::IndifferentAccess when IndiferentAccess is included in Dash - [@gregory](https://github.com/gregory).
* [#174](hashie/hashie#174): Fixed `from` and `transform_with` Trash features when IndifferentAccess is included - [@gregory](https://github.com/gregory).

## 3.0.0 (6/3/2014)

**Note:** This version introduces several backward incompatible API changes. See [UPGRADING](UPGRADING.md) for details.

* [#150](hashie/hashie#159): Handle nil intermediate object on deep fetch - [@stephenaument](https://github.com/stephenaument).
* [#146](hashie/hashie#146): Mash#respond_to? inconsistent with #method_missing and does not respond to #permitted? - [@dblock](https://github.com/dblock).
* [#152](hashie/hashie#152): Do not convert keys to String in Hashie::Dash and Hashie::Trash, use Hashie::Extensions::Dash::IndifferentAccess to achieve backward compatible behavior - [@dblock](https://github.com/dblock).
* [#152](hashie/hashie#152): Do not automatically stringify keys in Hashie::Hash#to_hash, pass `:stringify_keys` to achieve backward compatible behavior - [@dblock](https://github.com/dblock).
* [#148](hashie/hashie#148): Consolidated Hashie::Hash#stringify_keys implementation - [@dblock](https://github.com/dblock).
* [#149](hashie/hashie#149): Allow IgnoreUndeclared and DeepMerge to be used with undeclared properties - [@jhaesus](https://github.com/jhaesus).
  • Loading branch information
taca committed Feb 4, 2015
1 parent 088f23d commit d43d4e2
Show file tree
Hide file tree
Showing 3 changed files with 47 additions and 17 deletions.
4 changes: 2 additions & 2 deletions misc/ruby-hashie/Makefile
Original file line number Diff line number Diff line change
@@ -1,7 +1,7 @@
# $NetBSD: Makefile,v 1.1 2013/05/09 15:53:32 mef Exp $
# $NetBSD: Makefile,v 1.2 2015/02/04 15:25:37 taca Exp $
#

DISTNAME= hashie-1.2.0
DISTNAME= hashie-3.4.0
CATEGORIES= misc

MAINTAINER= tsutsui@NetBSD.org
Expand Down
52 changes: 41 additions & 11 deletions misc/ruby-hashie/PLIST
Original file line number Diff line number Diff line change
@@ -1,29 +1,59 @@
@comment $NetBSD: PLIST,v 1.1 2013/05/09 15:53:32 mef Exp $
@comment $NetBSD: PLIST,v 1.2 2015/02/04 15:25:37 taca Exp $
${GEM_HOME}/cache/${GEM_NAME}.gem
${GEM_LIBDIR}/.document
${GEM_LIBDIR}/.gitignore
${GEM_LIBDIR}/.rspec
${GEM_LIBDIR}/.travis.yml
${GEM_LIBDIR}/Gemfile
${GEM_LIBDIR}/Gemfile.lock
${GEM_LIBDIR}/Guardfile
${GEM_LIBDIR}/.yardopts
${GEM_LIBDIR}/CHANGELOG.md
${GEM_LIBDIR}/CONTRIBUTING.md
${GEM_LIBDIR}/LICENSE
${GEM_LIBDIR}/README.rdoc
${GEM_LIBDIR}/README.md
${GEM_LIBDIR}/Rakefile
${GEM_LIBDIR}/UPGRADING.md
${GEM_LIBDIR}/hashie.gemspec
${GEM_LIBDIR}/lib/hashie.rb
${GEM_LIBDIR}/lib/hashie/clash.rb
${GEM_LIBDIR}/lib/hashie/dash.rb
${GEM_LIBDIR}/lib/hashie/extensions/coercion.rb
${GEM_LIBDIR}/lib/hashie/extensions/dash/indifferent_access.rb
${GEM_LIBDIR}/lib/hashie/extensions/deep_fetch.rb
${GEM_LIBDIR}/lib/hashie/extensions/deep_find.rb
${GEM_LIBDIR}/lib/hashie/extensions/deep_merge.rb
${GEM_LIBDIR}/lib/hashie/extensions/ignore_undeclared.rb
${GEM_LIBDIR}/lib/hashie/extensions/indifferent_access.rb
${GEM_LIBDIR}/lib/hashie/extensions/key_conversion.rb
${GEM_LIBDIR}/lib/hashie/extensions/mash/safe_assignment.rb
${GEM_LIBDIR}/lib/hashie/extensions/merge_initializer.rb
${GEM_LIBDIR}/lib/hashie/extensions/method_access.rb
${GEM_LIBDIR}/lib/hashie/extensions/parsers/yaml_erb_parser.rb
${GEM_LIBDIR}/lib/hashie/extensions/pretty_inspect.rb
${GEM_LIBDIR}/lib/hashie/extensions/stringify_keys.rb
${GEM_LIBDIR}/lib/hashie/extensions/symbolize_keys.rb
${GEM_LIBDIR}/lib/hashie/hash.rb
${GEM_LIBDIR}/lib/hashie/hash_extensions.rb
${GEM_LIBDIR}/lib/hashie/mash.rb
${GEM_LIBDIR}/lib/hashie/rash.rb
${GEM_LIBDIR}/lib/hashie/trash.rb
${GEM_LIBDIR}/lib/hashie/version.rb
${GEM_LIBDIR}/spec/hashie/clash_spec.rb
${GEM_LIBDIR}/spec/hashie/dash_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/autoload_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/coercion_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/dash/indifferent_access_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/deep_fetch_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/deep_find_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/deep_merge_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/ignore_undeclared_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/indifferent_access_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/indifferent_access_with_rails_hwia_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/key_conversion_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/mash/safe_assignment_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/merge_initializer_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/method_access_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/stringify_keys_spec.rb
${GEM_LIBDIR}/spec/hashie/extensions/symbolize_keys_spec.rb
${GEM_LIBDIR}/spec/hashie/hash_spec.rb
${GEM_LIBDIR}/spec/hashie/mash_spec.rb
${GEM_LIBDIR}/spec/hashie/parsers/yaml_erb_parser_spec.rb
${GEM_LIBDIR}/spec/hashie/rash_spec.rb
${GEM_LIBDIR}/spec/hashie/trash_spec.rb
${GEM_LIBDIR}/spec/spec.opts
${GEM_LIBDIR}/spec/hashie/version_spec.rb
${GEM_LIBDIR}/spec/spec_helper.rb
${GEM_LIBDIR}/spec/support/module_context.rb
${GEM_HOME}/specifications/${GEM_NAME}.gemspec
8 changes: 4 additions & 4 deletions misc/ruby-hashie/distinfo
Original file line number Diff line number Diff line change
@@ -1,5 +1,5 @@
$NetBSD: distinfo,v 1.1 2013/05/09 15:53:32 mef Exp $
$NetBSD: distinfo,v 1.2 2015/02/04 15:25:37 taca Exp $

SHA1 (hashie-1.2.0.gem) = 0c716b850926cfedf018eef0b7ad6b35c8c9af9b
RMD160 (hashie-1.2.0.gem) = e3ada67027f7195dc60ce06956bcc1e0d574cc32
Size (hashie-1.2.0.gem) = 15872 bytes
SHA1 (hashie-3.4.0.gem) = a21a2d84d6fc5b6499c38388c09a9af17d39d9f5
RMD160 (hashie-3.4.0.gem) = 80db6cbe9cd14346e2c2671d97d81a40531e0a5f
Size (hashie-3.4.0.gem) = 51712 bytes

0 comments on commit d43d4e2

Please sign in to comment.