-
Notifications
You must be signed in to change notification settings - Fork 174
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
middleware: [sensor]support sc035hgs_1l [sample] vo layer framerate [sensor] Update the SC5336 driver configuration and make compatibility adjustments. [panel][bt1120] add panel nvp6021 [sensor]add gc2093 60fps [sensor]support sc3336p [V410][Phobos] add mipi switch support. [sensor] add sc2336_slave [sensor] add sc2331_slave [feat](Sensor): Add support for sensor SC2336P_1L. [sensor]modify 4336 4336p bayerpattern [sensor]add new sensor sc223a(linear mode can be used for sc233a) isp: [feat](toojson): update tooljson generation way. [feat] isp add for trinocular camera. [feat](isp) modify param type of VC module [awb] refine adjust saturation by CA memory use drv: [feature](venc): venc sbm mode suppor multiple chn [vpss] support multi chn(sbm + frm) online [V410][PHOBOS] add mipi switch support. remove useless code Change-Id: Ieb9e66c5f33e620e615fd752ba7d29229716bf5c
- Loading branch information
1 parent
b7e531d
commit fce93ce
Showing
259 changed files
with
26,713 additions
and
174 deletions.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
36 changes: 36 additions & 0 deletions
36
middleware/v2/component/isp/sensor/cv180x/sms_sc035hgs_1L/Makefile
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,36 @@ | ||
SHELL = /bin/bash | ||
ifeq ($(PARAM_FILE), ) | ||
PARAM_FILE=../../../../../../$(shell echo $(MW_VER))/Makefile.param | ||
include $(PARAM_FILE) | ||
endif | ||
|
||
SDIR = $(PWD) | ||
SRCS = $(wildcard $(SDIR)/*.c) | ||
INCS = -I$(MW_INC) -I$(ISP_INC) -I$(KERNEL_INC) -I./include | ||
OBJS = $(SRCS:.c=.o) | ||
DEPS = $(SRCS:.c=.d) | ||
TARGET_A = $(MW_LIB)/libsns_sc035hgs_1L.a | ||
TARGET_SO = $(MW_LIB)/libsns_sc035hgs_1L.so | ||
|
||
EXTRA_CFLAGS = $(INCS) | ||
EXTRA_LDFLAGS = | ||
|
||
.PHONY : clean all | ||
all : $(TARGET_A) $(TARGET_SO) | ||
|
||
$(SDIR)/%.o: $(SDIR)/%.c | ||
@$(CC) $(DEPFLAGS) $(CFLAGS) $(EXTRA_CFLAGS) -c $< -o $@ | ||
@echo [$(notdir $(CC))] $(notdir $@) | ||
|
||
$(TARGET_A): $(OBJS) | ||
@$(AR) $(ARFLAGS) $@ $(OBJS) | ||
@echo -e $(YELLOW)[LINK]$(END)[$(notdir $(AR))] $(notdir $(TARGET_A)) | ||
|
||
$(TARGET_SO): $(OBJS) | ||
@$(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) -o $@ --start-group $(OBJS) --end-group | ||
@echo -e $(GREEN)[LINK]$(END)[$(notdir $(LD))] $(notdir $(TARGET_SO)) | ||
|
||
clean: | ||
@rm -f $(OBJS) $(DEPS) $(TARGET_A) $(TARGET_SO) | ||
|
||
-include $(DEPS) |
Oops, something went wrong.