Skip to content

Commit

Permalink
Proper fix for DLL location instead of moving files
Browse files Browse the repository at this point in the history
  • Loading branch information
hmartinez82 committed Oct 3, 2023
1 parent e7949af commit 1b5e778
Show file tree
Hide file tree
Showing 2 changed files with 19 additions and 4 deletions.
12 changes: 12 additions & 0 deletions mingw-w64-calcmysky/003-dll-install-location.patch
Original file line number Diff line number Diff line change
@@ -0,0 +1,12 @@
diff -bur CalcMySky-0.3.1-orig/ShowMySky/CMakeLists.txt CalcMySky-0.3.1/ShowMySky/CMakeLists.txt
--- CalcMySky-0.3.1-orig/ShowMySky/CMakeLists.txt 2023-10-03 12:55:58.401386500 -0600
+++ CalcMySky-0.3.1/ShowMySky/CMakeLists.txt 2023-10-03 12:56:49.974489900 -0600
@@ -58,7 +58,7 @@
install(TARGETS ShowMySky
EXPORT ShowMySky-Qt${QT_VERSION}Config
LIBRARY DESTINATION "${installLibDir}"
- RUNTIME DESTINATION "${installLibDir}"
+ RUNTIME DESTINATION "${installBinDir}"
ARCHIVE DESTINATION "${installLibDir}"
INCLUDES DESTINATION "${installIncDir}"
)
11 changes: 7 additions & 4 deletions mingw-w64-calcmysky/PKGBUILD
Original file line number Diff line number Diff line change
Expand Up @@ -26,10 +26,12 @@ depends=(
)
source=("https://github.com/10110111/CalcMySky/archive/refs/tags/v${pkgver}.tar.gz"
"001-mingw.patch::https://github.com/10110111/CalcMySky/pull/17.patch"
"002-missing-symbol-clang-static-lib.patch")
"002-missing-symbol-clang-static-lib.patch"
"003-dll-install-location.patch")
sha256sums=('d284eaabcf21ad3d1f520a1d1b1b533f7c5f5a44ba92495dd38e238874e8e4d7'
'290b26213e9b139742135329df28ffb87dbb63db6809634dee013d0272f62756'
'e951d29ba317118692d892472be02b8d5395fba2b3b39cafa8335164444f0651')
'e951d29ba317118692d892472be02b8d5395fba2b3b39cafa8335164444f0651'
'2ffbc317cd73a8b0653b5691b411cd47634e6d075fcc3ed16cf3913271b38275')

apply_patch_with_msg() {
for _patch in "$@"
Expand All @@ -43,7 +45,8 @@ prepare() {
cd "${srcdir}"/${_realname}-${pkgver}
apply_patch_with_msg \
"001-mingw.patch" \
"002-missing-symbol-clang-static-lib.patch"
"002-missing-symbol-clang-static-lib.patch" \
"003-dll-install-location.patch"
}

build() {
Expand Down Expand Up @@ -77,7 +80,7 @@ package() {
DESTDIR=${pkgdir} ${MINGW_PREFIX}/bin/cmake.exe --install .

# Move DLLs to bin folder
mv "${pkgdir}${MINGW_PREFIX}/lib/"*.dll "${pkgdir}${MINGW_PREFIX}/bin/"
#mv "${pkgdir}${MINGW_PREFIX}/lib/"*.dll "${pkgdir}${MINGW_PREFIX}/bin/"

install -vDm 644 ${srcdir}/${_realname}-${pkgver}/COPYING -t "${pkgdir}${MINGW_PREFIX}/share/licenses/$_realname/"

Expand Down

0 comments on commit 1b5e778

Please sign in to comment.