Skip to content

Commit

Permalink
Merge pull request #10 from neo4j-labs/github-actions
Browse files Browse the repository at this point in the history
Add github-action workflow
  • Loading branch information
danielruminski authored Sep 17, 2023
2 parents 19a57a9 + c700d5e commit c070127
Show file tree
Hide file tree
Showing 2 changed files with 41 additions and 2 deletions.
39 changes: 39 additions & 0 deletions .github/workflows/master.yml
Original file line number Diff line number Diff line change
@@ -0,0 +1,39 @@
name: Python application

on:
push:
branches: ["master"]
pull_request:
branches: ["master"]

permissions:
contents: read

jobs:
build:
runs-on: ubuntu-latest
strategy:
matrix:
python-version: ["3.8", "3.9", "3.10"]

steps:
- uses: actions/checkout@v3
- name: Set up Python ${{ matrix.python-version }}
uses: actions/setup-python@v3
with:
python-version: ${{ matrix.python-version }}
- name: Install dependencies
run: |
python -m pip install --upgrade pip
pip install -r requirements.txt
pip install -r test-requirements.txt
pip install pylint black
- name: Format with black
run: |
black . --line-length=100 --experimental-string-processing
- name: Lint with Pylint
run: |
pylint aura/
- name: Test with pytest
run: |
pytest tests/unit
4 changes: 2 additions & 2 deletions setup.py
Original file line number Diff line number Diff line change
Expand Up @@ -13,7 +13,7 @@

setup(
name="aura-cli",
version=version['__version__'],
version=version["__version__"],
packages=find_packages(),
include_package_data=True,
install_requires=requirements,
Expand All @@ -22,4 +22,4 @@
[console_scripts]
aura=aura.aura:cli
""",
)
)

0 comments on commit c070127

Please sign in to comment.