Skip to content

Commit

Permalink
vlock: refresh patches
Browse files Browse the repository at this point in the history
WARNING:
Some of the context lines in patches were ignored. This can lead to incorrectly applied patches.
The context lines in the patches can be updated with devtool:

    devtool modify <recipe>
    devtool finish --force-patch-refresh <recipe> <layer_path>

Then the updated patches and the source tree (in devtool's workspace)
should be reviewed to make sure the patches apply in the correct place
and don't introduce duplicate lines (which can, and does happen
when some of the context is ignored). Further information:
http://lists.openembedded.org/pipermail/openembedded-core/2018-March/148675.html
https://bugzilla.yoctoproject.org/show_bug.cgi?id=10450
Details:
checking file Makefile
checking file configure
Hunk #3 succeeded at 232 (offset -4 lines).
Hunk #4 succeeded at 356 (offset -5 lines).
checking file src/vlock-main.c
Hunk #1 succeeded at 112 with fuzz 1 (offset 1 line).
Hunk #2 succeeded at 184 (offset 1 line).
Hunk #3 succeeded at 194 (offset 1 line).
Hunk #4 succeeded at 223 (offset 1 line).

among others

Signed-off-by: Armin Kuster <akuster808@gmail.com>
  • Loading branch information
akuster committed Apr 13, 2018
1 parent aaee985 commit d46d50c
Show file tree
Hide file tree
Showing 3 changed files with 58 additions and 26 deletions.
30 changes: 20 additions & 10 deletions meta-oe/recipes-extended/vlock/vlock-2.2.3/disable_vlockrc.patch
Original file line number Diff line number Diff line change
@@ -1,13 +1,23 @@
From f71cc920528c3496b0118964ebbcf5440cda4ed1 Mon Sep 17 00:00:00 2001
From: Jackie Huang <jackie.huang@windriver.com>
Date: Wed, 16 Aug 2017 13:37:40 +0800
Subject: [PATCH] vlock: add new recipe

Upstream-Status: Inappropriate [configuration]

written by: Jeff Polk <jeff.polk@windriver.com>
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>

Index: vlock-2.2.2/man/vlock.1
===================================================================
--- vlock-2.2.2.orig/man/vlock.1 2010-07-26 14:12:42.000000000 -0400
+++ vlock-2.2.2/man/vlock.1 2010-07-26 14:13:06.000000000 -0400
@@ -111,11 +111,6 @@
---
man/vlock.1 | 5 -----
src/vlock.sh | 5 -----
2 files changed, 10 deletions(-)

diff --git a/man/vlock.1 b/man/vlock.1
index 0d29b49..01cb944 100644
--- a/man/vlock.1
+++ b/man/vlock.1
@@ -111,11 +111,6 @@ enter your password at the password prompt. If this variable is unset or set
to an invalid value or 0 no timeout is used. \fBWarning\fR: If this value is
too low, you may not be able to unlock your session.
.PP
Expand All @@ -19,11 +29,11 @@ Index: vlock-2.2.2/man/vlock.1
.SH SECURITY
See the SECURITY file in the \fBvlock\fR distribution for more information.
.PP
Index: vlock-2.2.2/src/vlock.sh
===================================================================
--- vlock-2.2.2.orig/src/vlock.sh 2010-07-26 14:12:32.000000000 -0400
+++ vlock-2.2.2/src/vlock.sh 2010-07-26 14:13:33.000000000 -0400
@@ -35,11 +35,6 @@
diff --git a/src/vlock.sh b/src/vlock.sh
index 75f1369..f572776 100644
--- a/src/vlock.sh
+++ b/src/vlock.sh
@@ -35,11 +35,6 @@ This TTY is now locked.

${VLOCK_ENTER_PROMPT}"

Expand Down
35 changes: 24 additions & 11 deletions meta-oe/recipes-extended/vlock/vlock-2.2.3/vlock-no_tally.patch
Original file line number Diff line number Diff line change
@@ -1,8 +1,21 @@
From 17e5c8d32abc214aea408f0837be41e88bce7eb2 Mon Sep 17 00:00:00 2001
From: Jackie Huang <jackie.huang@windriver.com>
Date: Wed, 16 Aug 2017 13:37:40 +0800
Subject: [PATCH] vlock: add new recipe

Upstream-Status: Pending

written by: Jeff Polk <jeff.polk@windriver.com>
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>

---
Makefile | 4 ++++
configure | 9 +++++++++
src/vlock-main.c | 8 ++++++++
3 files changed, 21 insertions(+)

diff --git a/Makefile b/Makefile
index 4eeb42a..834cd2c 100644
--- a/Makefile
+++ b/Makefile
@@ -126,6 +126,10 @@ ifeq ($(AUTH_METHOD),shadow)
Expand All @@ -16,6 +29,8 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
ifeq ($(ENABLE_PLUGINS),yes)
vlock-main: plugins.o plugin.o module.o process.o script.o tsort.o list.o
# -rdynamic is needed so that the all plugin can access the symbols from console_switch.o
diff --git a/configure b/configure
index d5d84d6..1303598 100755
--- a/configure
+++ b/configure
@@ -44,6 +44,7 @@ Optional Features:
Expand All @@ -36,17 +51,15 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
pam|shadow)
if [ "$2" = "yes" ] ; then
if [ -n "$auth_method" ] && [ "$auth_method" != "$1" ] ; then
@@ -232,6 +232,7 @@ set_defaults() {
@@ -228,6 +232,7 @@ set_defaults() {
AUTH_METHOD="pam"
ENABLE_ROOT_PASSWORD="yes"
ENABLE_PLUGINS="yes"
+ ENABLE_FAIL_COUNT="yes"
SCRIPTS=""

VLOCK_GROUP="vlock"
@@ -356,10 +356,14 @@ ENABLE_PLUGINS = ${ENABLE_PLUGINS}
# which plugins should be build
MODULES = ${MODULES}
@@ -353,6 +358,10 @@ MODULES = ${MODULES}
# which scripts should be installed
SCRIPTS = ${SCRIPTS}

Expand All @@ -57,12 +70,12 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
# root's group
ROOT_GROUP = ${ROOT_GROUP}

# group for privileged plugins
VLOCK_GROUP = ${VLOCK_GROUP}
diff --git a/src/vlock-main.c b/src/vlock-main.c
index 008f6f0..108ce8b 100644
--- a/src/vlock-main.c
+++ b/src/vlock-main.c
@@ -111,7 +111,9 @@ static void restore_terminal(void)
(void) tcsetattr(STDIN_FILENO, TCSANOW, &term);
@@ -112,7 +112,9 @@ static void restore_terminal(void)
(void) tcsetattr(STDIN_FILENO, TCSANOW, &old_term);
}

+#ifdef ENABLE_FAIL_COUNT
Expand All @@ -71,7 +84,7 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>

static void auth_loop(const char *username)
{
@@ -181,7 +183,9 @@ static void auth_loop(const char *userna
@@ -182,7 +184,9 @@ static void auth_loop(const char *username)
}
#endif

Expand All @@ -81,7 +94,7 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
}

/* Free timeouts memory. */
@@ -189,11 +193,13 @@ static void auth_loop(const char *userna
@@ -190,11 +194,13 @@ static void auth_loop(const char *username)
free(prompt_timeout);
}

Expand All @@ -95,7 +108,7 @@ Signed-off-by: Jackie Huang <jackie.huang@windriver.com>

#ifdef USE_PLUGINS
static void call_end_hook(void)
@@ -216,7 +222,9 @@ int main(int argc, char *const argv[])
@@ -217,7 +223,9 @@ int main(int argc, char *const argv[])
if (username == NULL)
fatal_perror("vlock: could not get username");

Expand Down
Original file line number Diff line number Diff line change
@@ -1,13 +1,22 @@
From fcec4e7fe899f8c0077b3004eeccb7292a945a67 Mon Sep 17 00:00:00 2001
From: Jackie Huang <jackie.huang@windriver.com>
Date: Wed, 16 Aug 2017 13:37:40 +0800
Subject: [PATCH] vlock: add new recipe

Upstream-Status: Pending

written by: Jeff Polk <jeff.polk@windriver.com>
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>

Index: vlock-2.2.2/src/auth-pam.c
===================================================================
--- vlock-2.2.2.orig/src/auth-pam.c 2010-06-14 14:38:51.000000000 -0400
+++ vlock-2.2.2/src/auth-pam.c 2010-06-14 14:39:12.000000000 -0400
@@ -148,6 +148,9 @@
---
src/auth-pam.c | 3 +++
1 file changed, 3 insertions(+)

diff --git a/src/auth-pam.c b/src/auth-pam.c
index 5cf93f6..c5cc67a 100644
--- a/src/auth-pam.c
+++ b/src/auth-pam.c
@@ -148,6 +148,9 @@ bool auth(const char *user, struct timespec *timeout)

if (pam_status != PAM_SUCCESS) {
fprintf(stderr, "vlock: %s\n", pam_strerror(pamh, pam_status));
Expand Down

0 comments on commit d46d50c

Please sign in to comment.