Skip to content

Commit

Permalink
luci-mod-rdash: add new package with fixes
Browse files Browse the repository at this point in the history
This commit includes:
- Adding the new package.
- Renaming the package and replacing old files.
- Adding an extra line at the end of files.

Signed-off-by: Rick Clark <tplink.82d1@proton.me>
  • Loading branch information
tp82d1 committed Nov 30, 2024
1 parent d56caf8 commit e9e3667
Show file tree
Hide file tree
Showing 16 changed files with 1,094 additions and 0 deletions.
34 changes: 34 additions & 0 deletions modules/luci-mod-rdash/Makefile
Original file line number Diff line number Diff line change
@@ -0,0 +1,34 @@
include $(TOPDIR)/rules.mk

LUCI_TITLE:=rdash
LUCI_PKGARCH:=all


include $(INCLUDE_DIR)/package.mk

define Package/luci-mod-rdash
SECTION:=luci
CATEGORY:=LuCI
SUBMENU:=2. Modules
TITLE:=$(LUCI_TITLE)
PKGARCH:=$(LUCI_PKGARCH)
endef

define Build/Configure
# No configure step needed
endef

define Build/Compile
# No compile step needed
endef

define Package/luci-mod-rdash/install
$(INSTALL_DIR) $(1)/www/luci-static/resources/view/rdash
$(CP) ./htdocs/luci-static/resources/view/rdash/* $(1)/www/luci-static/resources/view/rdash/
$(INSTALL_DIR) $(1)/usr/share/luci/menu.d
$(CP) ./root/usr/share/luci/menu.d/* $(1)/usr/share/luci/menu.d/
$(INSTALL_DIR) $(1)/usr/share/rpcd/acl.d
$(CP) ./root/usr/share/rpcd/acl.d/* $(1)/usr/share/rpcd/acl.d/
endef

$(eval $(call BuildPackage,luci-mod-rdash))
Original file line number Diff line number Diff line change
@@ -0,0 +1,300 @@
.dashboard-container {
display: flex;
justify-content: center;
align-items: center;
margin:35px 0
}

.icon {
width: 100px;
height: auto;
cursor: pointer;
transition: transform .3s;
padding-bottom:.7em
}

.icon:hover {
opacity: .7;
transform:scale(1)
}

.separator {
width: 230px;
height: 2px;
background-color: #ccc;
margin:0 10px
}

.cbi-button-save, .cbi-button-apply, .cbi-button-reset, .cbi-page-actions {
display:none !important
}

.system-info-cards, .storage-info-details, .memory-info-details {
display: flex;
flex-wrap: wrap;
gap: 20px;
padding:10px
}

.storage-info-details, .memory-info-details {
padding-top:1.5em
}

.info-card {
background: #f9f9f9;
border: 1px solid #ddd;
border-radius: 8px;
padding: 16px;
flex: 1 1 200px;
box-shadow: 0 4px 8px rgba(0, 0, 0, .1);
transition:transform .2s ease-in-out
}

.info-card h3 {
margin: 0 0 8px;
text-align: center;
font-size:1.2em
}

.info-card p {
margin: 0;
text-align: center;
font-size:1em
}

.info-card:hover {
transform:scale(1.05)
}

.internet-status-container {
text-align: center;
margin-top:20px
}

.internet-icon {
margin-bottom:10px
}

.internet-status {
margin-top: 10px;
padding: 10px;
display: flex;
margin: auto;
flex-wrap:wrap
}

.internet-card {
background: #f9f9f9;
border: 1px solid #ddd;
border-radius: 8px;
padding: 20px;
width: 50%;
box-shadow: 0 4px 8px rgba(0, 0, 0, .1);
transition:transform .2s ease-in-out
}

.internet-card:hover {
transform:scale(1.05)
}

.internet-card h3 {
display: flex;
align-items: center;
font-size: 1.4rem;
margin-bottom: 15px;
color:#333
}

.status-line {
margin-bottom: 10px;
font-size:1rem
}

.status-label {
font-weight: bold;
color:#666
}

.status-value {
font-weight: normal;
color:#333
}

.status-value.connected {
color:#28a745
}

.status-value.disconnected {
color:#dc3545
}

.cbi-progressbar-infolink {
border: 1px solid var(--border-color-high);
border-radius: 5px;
position: relative;
min-width: 170px;
height: 12px;
background: #e0e0e0;
margin: 1.4em 0 4px;
box-shadow:inset 0 2px 4px rgba(0, 0, 0, .3)
}

.cbi-progressbar-infolink > div {
background: linear-gradient(to right, #3e55e4, #87d7ee);
height: 100%;
transition: width .25s ease-in, box-shadow .25s ease-in;
width: 0;
border-radius: 5px;
box-shadow:0 0 5px rgba(0, 0, 0, .5)
}

.cbi-progressbar-infolink::before {
position: absolute;
top: -1.4em;
left: 0;
content: attr(title);
white-space: pre;
overflow: hidden;
text-overflow: ellipsis;
font-weight: bold;
color: #333;
padding:0 5px
}

.internet-card:hover .status-value {
color:#000
}

@media (max-width: 768px) {
.internet-card {
width:100%
}
}

.device-count {
background: #f9f9f9;
border: 1px solid #ddd;
border-radius: 8px;
padding: 20px;
box-shadow: 0 4px 8px rgba(0, 0, 0, .1);
transition: transform .2s ease-in-out;
margin-bottom: 20px;
text-align:center
}

.connected-title {
font-size: 1.8em;
font-weight: bold;
color: black;
margin-bottom:10px
}

.connected-count {
font-size: 2.5em;
font-weight: bold;
color: #007BFF;
padding: 10px 15px;
border-radius:5px
}

.leases-title {
font-size: 1.5em;
font-weight: bold;
color: #333;
margin:30px 0 10px
}

.table {
width: 100%;
border-collapse:collapse
}

.table th, .table td {
border: 1px solid #ddd;
padding: 12px;
text-align:left
}

.table th {
background-color: black;
color:white
}

.table tr:nth-child(even) {
background-color:#f9f9f9
}

.table tr:hover {
background-color:#c4c4c4
}

.icon {
position:relative
}

.notification-badge {
position: absolute;
top: 0;
right: 0;
background-color: rgb(255, 230, 0);
color: black;
border-radius: 50%;
padding: .5em;
font-size: 1.1em;
font-weight: bold;
line-height: .9;
min-width: 1.8em;
text-align: center;
display:block
}

.icon-container {
display: flex;
flex-direction: column;
align-items: center;
margin: 20px;
cursor:pointer
}

.icon-label {
margin-top: 1px;
font-size: 14px;
font-weight: 360;
color: #000;
text-align:center
}

.icon-container .icon-label.active {
color: #45c8d4;
font-weight:700
}

.internet-badge {
width: 24px;
height: 24px;
background-size: contain;
background-repeat: no-repeat;
background-position: center;
display: block;
color:transparent
}

.dhcp-badge {
display:block
}

.h2-System-Information, .h2-Information, .h2-Storage-Information {
font-weight: 700;
color: black;
font-size: 24px;
line-height:36px
}

.h2-System-Information {
padding-bottom:.5em
}

.h2-Information, .h2-Storage-Information {
padding: 2em 0 .4em
}

Loading
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Loading
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Loading
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Loading
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Loading
Sorry, something went wrong. Reload?
Sorry, we cannot display this file.
Sorry, this file is invalid so it cannot be displayed.
Loading

0 comments on commit e9e3667

Please sign in to comment.