Nix Flake for SpectaQL
Provide Nix Flake for SpectaQL, GraphQL API Document Generator.
{
inputs = {
nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
flake-utils.url = "github:numtide/flake-utils";
spectaql.url = "github:otomadb/spectaql.nix";
devshell.url = "github:numtide/devshell";
};
outputs = {
self,
nixpkgs,
flake-utils,
...
} @ inputs:
flake-utils.lib.eachDefaultSystem (
system: let
pkgs = import nixpkgs {
inherit system;
overlays = with inputs; [
devshell.overlays.default
spectaql.overlays.default
];
};
in {
devShells.default = pkgs.devshell.mkShell {
packages = with pkgs; [
spectaql
];
};
}
);
}
Refer to otomadb/graphql-api-document.