-
-
Notifications
You must be signed in to change notification settings - Fork 3.1k
Commit
This commit does not belong to any branch on this repository, and may belong to a fork outside of the repository.
fix(main/libevent): override FindThreads configure step
The cmake test to find the pthreads functions looks for pthread_cancel, which is not implemented on android. As such, it fails to find any library with pthread functionality, and the configure step fails. This is a cmake issue and not a libevent issue.
- Loading branch information
Showing
2 changed files
with
13 additions
and
1 deletion.
There are no files selected for viewing
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters
Original file line number | Diff line number | Diff line change |
---|---|---|
@@ -0,0 +1,12 @@ | ||
--- ./CMakeLists.txt.orig 2022-08-30 11:05:57.580636738 +0200 | ||
+++ ./CMakeLists.txt 2022-08-30 11:06:47.268305387 +0200 | ||
@@ -859,7 +859,8 @@ | ||
if (WIN32) | ||
list(APPEND SRC_CORE evthread_win32.c) | ||
else() | ||
- find_package(Threads REQUIRED) | ||
+ set(CMAKE_THREAD_LIBS_INIT "") | ||
+ set(CMAKE_USE_PTHREADS_INIT 1) | ||
if (NOT CMAKE_USE_PTHREADS_INIT) | ||
message(FATAL_ERROR | ||
"Failed to find Pthreads, set EVENT__DISABLE_THREAD_SUPPORT to disable") |
This file contains bidirectional Unicode text that may be interpreted or compiled differently than what appears below. To review, open the file in an editor that reveals hidden Unicode characters.
Learn more about bidirectional Unicode characters