Skip to content

Commit

Permalink
devel/mise: update to 2024.12.2
Browse files Browse the repository at this point in the history
## [2024.12.2](https://github.com/jdx/mise/compare/v2024.12.1..v2024.12.2) - 2024-12-07

### 🚀 Features

- **(registry)** add zls to registry by [@hverlin](https://github.com/hverlin) in [#3392](jdx/mise#3392)
- Add --json-extended option to mise env by [@hverlin](https://github.com/hverlin) in [#3389](jdx/mise#3389)

### 🐛 Bug Fixes

- **(config)** set config_root for tasks defined in included toml files by [@risu729](https://github.com/risu729) in [#3388](jdx/mise#3388)
- global hooks by [@jdx](https://github.com/jdx) in [#3393](jdx/mise#3393)
- only run watch_file hook when it has changed file by [@jdx](https://github.com/jdx) in [#3394](jdx/mise#3394)
- bug with aliasing core tools by [@jdx](https://github.com/jdx) in [#3395](jdx/mise#3395)
- remove shims directory before activating by [@jdx](https://github.com/jdx) in [#3396](jdx/mise#3396)

### 🚜 Refactor

- use github crate to list zig releases by [@risu729](https://github.com/risu729) in [#3386](jdx/mise#3386)

### 📚 Documentation

- add zig to core tools by [@risu729](https://github.com/risu729) in [#3385](jdx/mise#3385)

### 🔍 Other Changes

- debug log by [@jdx](https://github.com/jdx) in [0075db0](jdx/mise@0075db0)

## [2024.12.1](https://github.com/jdx/mise/compare/v2024.12.0..v2024.12.1) - 2024-12-06

### 🚀 Features

- **(registry)** use aqua for some tools by [@risu729](https://github.com/risu729) in [#3375](jdx/mise#3375)
- allow filtering `mise bin-paths` on tools by [@jdx](https://github.com/jdx) in [#3367](jdx/mise#3367)
- added aws-cli from aqua by [@jdx](https://github.com/jdx) in [#3370](jdx/mise#3370)
- multiple MISE_ENV environments by [@jdx](https://github.com/jdx) in [#3371](jdx/mise#3371)
- add mise-task.json schema by [@hverlin](https://github.com/hverlin) in [#3374](jdx/mise#3374)
- automatically call `hook-env` by [@jdx](https://github.com/jdx) in [#3373](jdx/mise#3373)

### 🐛 Bug Fixes

- **(docs)** correct syntax error in IDE integration examples by [@EricGusmao](https://github.com/EricGusmao) in [#3360](jdx/mise#3360)
- ensure version check message is displayed by [@jdx](https://github.com/jdx) in [#3358](jdx/mise#3358)
- show warning if no precompiled pythons found by [@jdx](https://github.com/jdx) in [#3359](jdx/mise#3359)
- allow compilation not on macOS, Linux, or Windows by [@avysk](https://github.com/avysk) in [#3363](jdx/mise#3363)
- make hook-env compatible with zsh auto_name_dirs by [@jdx](https://github.com/jdx) in [#3366](jdx/mise#3366)
- skip optional env._.file files by [@jdx](https://github.com/jdx) in [#3381](jdx/mise#3381)
- .terraform-version by [@jdx](https://github.com/jdx) in [#3380](jdx/mise#3380)

### 📚 Documentation

- update auto-completion docs by [@hverlin](https://github.com/hverlin) in [#3355](jdx/mise#3355)
- fix `Environment variables passed to tasks` section by [@hverlin](https://github.com/hverlin) in [#3378](jdx/mise#3378)

### 🧪 Testing

- try to fix coverage rate limits by [@jdx](https://github.com/jdx) in [#3384](jdx/mise#3384)

### 🔍 Other Changes

- Update shims.md by [@jdx](https://github.com/jdx) in [2d48109](jdx/mise@2d48109)
- Update hooks.md by [@jdx](https://github.com/jdx) in [2693f94](jdx/mise@2693f94)

### New Contributors

- @avysk made their first contribution in [#3363](jdx/mise#3363)
- @EricGusmao made their first contribution in [#3360](jdx/mise#3360)

## [2024.12.0](https://github.com/jdx/mise/compare/v2024.11.37..v2024.12.0) - 2024-12-04

### 🚀 Features

- **(erlang)** use precompiled binaries for macos by [@jdx](https://github.com/jdx) in [#3353](jdx/mise#3353)
- add upctl by [@scop](https://github.com/scop) in [#3309](jdx/mise#3309)
- Add `json-with-sources` option to settings ls by [@hverlin](https://github.com/hverlin) in [#3307](jdx/mise#3307)
- add ripsecrets to registry.toml by [@boris-smidt-klarrio](https://github.com/boris-smidt-klarrio) in [#3334](jdx/mise#3334)
- Add kyverno-cli by [@boris-smidt-klarrio](https://github.com/boris-smidt-klarrio) in [#3336](jdx/mise#3336)

### 🐛 Bug Fixes

- add exec to `mise g git-pre-commit` by [@jdx](https://github.com/jdx) in [27a3aef](jdx/mise@27a3aef)
- bake gpg keys in by [@jdx](https://github.com/jdx) in [#3318](jdx/mise#3318)
- deprecate `mise local|global` by [@jdx](https://github.com/jdx) in [#3350](jdx/mise#3350)

### 🚜 Refactor

- use aqua for ruff by [@scop](https://github.com/scop) in [#3316](jdx/mise#3316)

### 📚 Documentation

- add terraform recipe to the cookbook by [@AliSajid](https://github.com/AliSajid) in [#3305](jdx/mise#3305)
- fix git examples for cargo backend by [@tmeijn](https://github.com/tmeijn) in [#3335](jdx/mise#3335)

### 🧪 Testing

- remove non-working maven test by [@jdx](https://github.com/jdx) in [5a3ed16](jdx/mise@5a3ed16)
- remove gleam by [@jdx](https://github.com/jdx) in [fdfe20b](jdx/mise@fdfe20b)
- use latest golang in e2e test by [@jdx](https://github.com/jdx) in [#3349](jdx/mise#3349)

### 🔍 Other Changes

- Update tips-and-tricks.md by [@jdx](https://github.com/jdx) in [5071419](jdx/mise@5071419)
- Update tips-and-tricks.md by [@jdx](https://github.com/jdx) in [fcc6b59](jdx/mise@fcc6b59)
- Update tips-and-tricks.md by [@jdx](https://github.com/jdx) in [039b19d](jdx/mise@039b19d)
- Update configuration.md by [@jdx](https://github.com/jdx) in [b0cac9e](jdx/mise@b0cac9e)
- Update tips-and-tricks.md by [@jdx](https://github.com/jdx) in [9347be8](jdx/mise@9347be8)
- Update tips-and-tricks.md by [@jdx](https://github.com/jdx) in [1cfc822](jdx/mise@1cfc822)
- Update registry.toml by [@jdx](https://github.com/jdx) in [5a28860](jdx/mise@5a28860)
- upgrade usage-lib by [@jdx](https://github.com/jdx) in [554d533](jdx/mise@554d533)
- add rust to core tools list by [@gurgelio](https://github.com/gurgelio) in [#3341](jdx/mise#3341)
- use asdf:mise-plugins/mise-nim by [@jdx](https://github.com/jdx) in [#3352](jdx/mise#3352)

### New Contributors

- @gurgelio made their first contribution in [#3341](jdx/mise#3341)
- @tmeijn made their first contribution in [#3335](jdx/mise#3335)
- @boris-smidt-klarrio made their first contribution in [#3336](jdx/mise#3336)
- @AliSajid made their first contribution in [#3305](jdx/mise#3305)

## [2024.11.37](https://github.com/jdx/mise/compare/v2024.11.36..v2024.11.37) - 2024-11-30

### 🚀 Features

- add black by [@scop](https://github.com/scop) in [#3292](jdx/mise#3292)
- migrate more tools away from asdf by [@jdx](https://github.com/jdx) in [40f92c6](jdx/mise@40f92c6)

### 🐛 Bug Fixes

- handle General/Complex Versioning in --bump by [@liskin](https://github.com/liskin) in [#2889](jdx/mise#2889)
- broken path example by [@minddust](https://github.com/minddust) in [#3296](jdx/mise#3296)
- swift path on macos by [@jdx](https://github.com/jdx) in [#3299](jdx/mise#3299)
- do not auto-install on `mise x` if some tools are passed by [@jdx](https://github.com/jdx) in [35d31a1](jdx/mise@35d31a1)
- fix: also make certain we are not auto installing inside shims by checking by [@jdx](https://github.com/jdx) in [b0c4a74](jdx/mise@b0c4a74)
- cache github release information for 24 hours by [@jdx](https://github.com/jdx) in [#3300](jdx/mise#3300)

### 🚜 Refactor

- use aqua for snyk by [@scop](https://github.com/scop) in [#3290](jdx/mise#3290)

### 🔍 Other Changes

- Revert "fix: always prefer glibc to musl in mise run " by [@jdx](https://github.com/jdx) in [#3298](jdx/mise#3298)
- bump expr-lang by [@jdx](https://github.com/jdx) in [#3297](jdx/mise#3297)
- mise up --bump by [@jdx](https://github.com/jdx) in [6872b54](jdx/mise@6872b54)
- update mise.lock by [@jdx](https://github.com/jdx) in [4c12502](jdx/mise@4c12502)
- disable tool tests until I can sort out gh rate limit issues by [@jdx](https://github.com/jdx) in [f42f010](jdx/mise@f42f010)

### New Contributors

- @minddust made their first contribution in [#3296](jdx/mise#3296)

## [2024.11.36](https://github.com/jdx/mise/compare/v2024.11.35..v2024.11.36) - 2024-11-29

### 🔍 Other Changes

- mise i by [@jdx](https://github.com/jdx) in [8150732](jdx/mise@8150732)

## [2024.11.35](https://github.com/jdx/mise/compare/v2024.11.34..v2024.11.35) - 2024-11-29

### 🚀 Features

- migrate more tools away from asdf by [@jdx](https://github.com/jdx) in [#3279](jdx/mise#3279)

### 🐛 Bug Fixes

- remove conflicting MISE_SHELL setting by [@jdx](https://github.com/jdx) in [#3284](jdx/mise#3284)

### 🚜 Refactor

- simplify __MISE_WATCH variable to only contain the most recent timestamp by [@jdx](https://github.com/jdx) in [#3282](jdx/mise#3282)

### 🧪 Testing

- remove unnecessary cargo-binstall test by [@jdx](https://github.com/jdx) in [0a4da7a](jdx/mise@0a4da7a)

### 🔍 Other Changes

- dont require build-windows before unit-windows by [@jdx](https://github.com/jdx) in [c85e2ec](jdx/mise@c85e2ec)
  • Loading branch information
0323pin committed Dec 8, 2024
1 parent 5c009ca commit fd41a7b
Show file tree
Hide file tree
Showing 3 changed files with 159 additions and 227 deletions.
4 changes: 2 additions & 2 deletions devel/mise/Makefile
Original file line number Diff line number Diff line change
@@ -1,6 +1,6 @@
# $NetBSD: Makefile,v 1.46 2024/11/29 08:34:03 pin Exp $
# $NetBSD: Makefile,v 1.47 2024/12/08 17:23:04 pin Exp $

DISTNAME= mise-2024.11.34
DISTNAME= mise-2024.12.2
CATEGORIES= devel
MASTER_SITES= ${MASTER_SITE_GITHUB:=jdx/}
GITHUB_TAG= v${PKGVERSION_NOREV}
Expand Down
95 changes: 39 additions & 56 deletions devel/mise/cargo-depends.mk
Original file line number Diff line number Diff line change
@@ -1,4 +1,4 @@
# $NetBSD: cargo-depends.mk,v 1.45 2024/11/29 08:34:03 pin Exp $
# $NetBSD: cargo-depends.mk,v 1.46 2024/12/08 17:23:04 pin Exp $

CARGO_CRATE_DEPENDS+= addr2line-0.21.0
CARGO_CRATE_DEPENDS+= adler-1.0.2
Expand All @@ -14,10 +14,9 @@ CARGO_CRATE_DEPENDS+= anstyle-1.0.10
CARGO_CRATE_DEPENDS+= anstyle-parse-0.2.6
CARGO_CRATE_DEPENDS+= anstyle-query-1.1.2
CARGO_CRATE_DEPENDS+= anstyle-wincon-3.0.6
CARGO_CRATE_DEPENDS+= anyhow-1.0.93
CARGO_CRATE_DEPENDS+= anyhow-1.0.94
CARGO_CRATE_DEPENDS+= arbitrary-1.4.1
CARGO_CRATE_DEPENDS+= arrayvec-0.5.2
CARGO_CRATE_DEPENDS+= ascii-canvas-4.0.0
CARGO_CRATE_DEPENDS+= async-compression-0.4.18
CARGO_CRATE_DEPENDS+= atomic-waker-1.1.2
CARGO_CRATE_DEPENDS+= autocfg-1.4.0
Expand All @@ -26,9 +25,7 @@ CARGO_CRATE_DEPENDS+= base64-0.22.1
CARGO_CRATE_DEPENDS+= base64ct-1.6.0
CARGO_CRATE_DEPENDS+= binstall-tar-0.4.42
CARGO_CRATE_DEPENDS+= bit-set-0.6.0
CARGO_CRATE_DEPENDS+= bit-set-0.8.0
CARGO_CRATE_DEPENDS+= bit-vec-0.7.0
CARGO_CRATE_DEPENDS+= bit-vec-0.8.0
CARGO_CRATE_DEPENDS+= bitflags-2.6.0
CARGO_CRATE_DEPENDS+= block-buffer-0.10.4
CARGO_CRATE_DEPENDS+= bstr-1.11.0
Expand All @@ -41,18 +38,18 @@ CARGO_CRATE_DEPENDS+= bzip2-0.4.4
CARGO_CRATE_DEPENDS+= bzip2-sys-0.1.11+1.0.8
CARGO_CRATE_DEPENDS+= calm_io-0.1.1
CARGO_CRATE_DEPENDS+= calmio_filters-0.1.0
CARGO_CRATE_DEPENDS+= cc-1.2.1
CARGO_CRATE_DEPENDS+= cc-1.2.3
CARGO_CRATE_DEPENDS+= cfg-if-1.0.0
CARGO_CRATE_DEPENDS+= cfg_aliases-0.2.1
CARGO_CRATE_DEPENDS+= chrono-0.4.38
CARGO_CRATE_DEPENDS+= chrono-tz-0.9.0
CARGO_CRATE_DEPENDS+= chrono-tz-build-0.3.0
CARGO_CRATE_DEPENDS+= ci_info-0.14.14
CARGO_CRATE_DEPENDS+= cipher-0.4.4
CARGO_CRATE_DEPENDS+= clap-4.5.21
CARGO_CRATE_DEPENDS+= clap_builder-4.5.21
CARGO_CRATE_DEPENDS+= clap-4.5.23
CARGO_CRATE_DEPENDS+= clap_builder-4.5.23
CARGO_CRATE_DEPENDS+= clap_derive-4.5.18
CARGO_CRATE_DEPENDS+= clap_lex-0.7.3
CARGO_CRATE_DEPENDS+= clap_lex-0.7.4
CARGO_CRATE_DEPENDS+= clap_mangen-0.2.24
CARGO_CRATE_DEPENDS+= color-eyre-0.6.3
CARGO_CRATE_DEPENDS+= color-print-0.3.7
Expand Down Expand Up @@ -96,7 +93,6 @@ CARGO_CRATE_DEPENDS+= dunce-1.0.5
CARGO_CRATE_DEPENDS+= ed25519-2.2.3
CARGO_CRATE_DEPENDS+= ed25519-dalek-2.1.1
CARGO_CRATE_DEPENDS+= either-1.13.0
CARGO_CRATE_DEPENDS+= ena-0.14.3
CARGO_CRATE_DEPENDS+= encode_unicode-0.3.6
CARGO_CRATE_DEPENDS+= encoding_rs-0.8.35
CARGO_CRATE_DEPENDS+= env_filter-0.1.2
Expand All @@ -108,7 +104,7 @@ CARGO_CRATE_DEPENDS+= errno-0.2.8
CARGO_CRATE_DEPENDS+= errno-0.3.10
CARGO_CRATE_DEPENDS+= errno-dragonfly-0.1.2
CARGO_CRATE_DEPENDS+= exec-0.3.1
CARGO_CRATE_DEPENDS+= expr-lang-0.1.6
CARGO_CRATE_DEPENDS+= expr-lang-0.2.1
CARGO_CRATE_DEPENDS+= eyre-0.6.12
CARGO_CRATE_DEPENDS+= fastrand-2.2.0
CARGO_CRATE_DEPENDS+= fiat-crypto-0.2.9
Expand Down Expand Up @@ -144,7 +140,7 @@ CARGO_CRATE_DEPENDS+= hermit-abi-0.3.9
CARGO_CRATE_DEPENDS+= hmac-0.12.1
CARGO_CRATE_DEPENDS+= home-0.5.9
CARGO_CRATE_DEPENDS+= homedir-0.3.4
CARGO_CRATE_DEPENDS+= http-1.1.0
CARGO_CRATE_DEPENDS+= http-1.2.0
CARGO_CRATE_DEPENDS+= http-body-1.0.1
CARGO_CRATE_DEPENDS+= http-body-util-0.1.2
CARGO_CRATE_DEPENDS+= httparse-1.9.5
Expand All @@ -171,7 +167,7 @@ CARGO_CRATE_DEPENDS+= idna_adapter-1.2.0
CARGO_CRATE_DEPENDS+= ignore-0.4.23
CARGO_CRATE_DEPENDS+= indenter-0.3.3
CARGO_CRATE_DEPENDS+= indexmap-1.9.3
CARGO_CRATE_DEPENDS+= indexmap-2.6.0
CARGO_CRATE_DEPENDS+= indexmap-2.7.0
CARGO_CRATE_DEPENDS+= indicatif-0.17.9
CARGO_CRATE_DEPENDS+= indoc-2.0.5
CARGO_CRATE_DEPENDS+= inout-0.1.3
Expand All @@ -181,16 +177,13 @@ CARGO_CRATE_DEPENDS+= is_terminal_polyfill-1.70.1
CARGO_CRATE_DEPENDS+= itertools-0.13.0
CARGO_CRATE_DEPENDS+= itoa-1.0.14
CARGO_CRATE_DEPENDS+= jobserver-0.1.32
CARGO_CRATE_DEPENDS+= js-sys-0.3.72
CARGO_CRATE_DEPENDS+= js-sys-0.3.76
CARGO_CRATE_DEPENDS+= junction-1.2.0
CARGO_CRATE_DEPENDS+= kdl-4.6.0
CARGO_CRATE_DEPENDS+= keccak-0.1.5
CARGO_CRATE_DEPENDS+= lalrpop-0.22.0
CARGO_CRATE_DEPENDS+= lalrpop-util-0.22.0
CARGO_CRATE_DEPENDS+= lazy-regex-3.3.0
CARGO_CRATE_DEPENDS+= lazy-regex-proc_macros-3.3.0
CARGO_CRATE_DEPENDS+= lazy_static-1.5.0
CARGO_CRATE_DEPENDS+= libc-0.2.166
CARGO_CRATE_DEPENDS+= libc-0.2.167
CARGO_CRATE_DEPENDS+= libgit2-sys-0.17.0+1.8.1
CARGO_CRATE_DEPENDS+= libm-0.2.11
CARGO_CRATE_DEPENDS+= libredox-0.1.3
Expand All @@ -217,12 +210,11 @@ CARGO_CRATE_DEPENDS+= mime-0.3.17
CARGO_CRATE_DEPENDS+= minimal-lexical-0.2.1
CARGO_CRATE_DEPENDS+= miniz_oxide-0.7.4
CARGO_CRATE_DEPENDS+= miniz_oxide-0.8.0
CARGO_CRATE_DEPENDS+= mio-1.0.2
CARGO_CRATE_DEPENDS+= mlua-0.10.1
CARGO_CRATE_DEPENDS+= mlua-sys-0.6.5
CARGO_CRATE_DEPENDS+= mlua_derive-0.10.0
CARGO_CRATE_DEPENDS+= mio-1.0.3
CARGO_CRATE_DEPENDS+= mlua-0.10.2
CARGO_CRATE_DEPENDS+= mlua-sys-0.6.6
CARGO_CRATE_DEPENDS+= mlua_derive-0.10.1
CARGO_CRATE_DEPENDS+= native-tls-0.2.12
CARGO_CRATE_DEPENDS+= new_debug_unreachable-1.0.6
CARGO_CRATE_DEPENDS+= nix-0.29.0
CARGO_CRATE_DEPENDS+= nom-7.1.3
CARGO_CRATE_DEPENDS+= nt-time-0.8.1
Expand Down Expand Up @@ -251,17 +243,15 @@ CARGO_CRATE_DEPENDS+= path-absolutize-3.1.1
CARGO_CRATE_DEPENDS+= path-dedot-3.1.1
CARGO_CRATE_DEPENDS+= pbkdf2-0.12.2
CARGO_CRATE_DEPENDS+= percent-encoding-2.3.1
CARGO_CRATE_DEPENDS+= pest-2.7.14
CARGO_CRATE_DEPENDS+= pest_derive-2.7.14
CARGO_CRATE_DEPENDS+= pest_generator-2.7.14
CARGO_CRATE_DEPENDS+= pest_meta-2.7.14
CARGO_CRATE_DEPENDS+= pest-2.7.15
CARGO_CRATE_DEPENDS+= pest_derive-2.7.15
CARGO_CRATE_DEPENDS+= pest_generator-2.7.15
CARGO_CRATE_DEPENDS+= pest_meta-2.7.15
CARGO_CRATE_DEPENDS+= petgraph-0.6.5
CARGO_CRATE_DEPENDS+= phf-0.11.2
CARGO_CRATE_DEPENDS+= phf_codegen-0.11.2
CARGO_CRATE_DEPENDS+= phf_generator-0.11.2
CARGO_CRATE_DEPENDS+= phf_shared-0.10.0
CARGO_CRATE_DEPENDS+= phf_shared-0.11.2
CARGO_CRATE_DEPENDS+= pico-args-0.5.0
CARGO_CRATE_DEPENDS+= pin-project-lite-0.2.15
CARGO_CRATE_DEPENDS+= pin-utils-0.1.0
CARGO_CRATE_DEPENDS+= pkcs8-0.10.2
Expand All @@ -270,10 +260,7 @@ CARGO_CRATE_DEPENDS+= platforms-3.5.0
CARGO_CRATE_DEPENDS+= portable-atomic-1.10.0
CARGO_CRATE_DEPENDS+= powerfmt-0.2.0
CARGO_CRATE_DEPENDS+= ppv-lite86-0.2.20
CARGO_CRATE_DEPENDS+= precomputed-hash-0.1.1
CARGO_CRATE_DEPENDS+= pretty_assertions-1.4.1
CARGO_CRATE_DEPENDS+= proc-macro-error-1.0.4
CARGO_CRATE_DEPENDS+= proc-macro-error-attr-1.0.4
CARGO_CRATE_DEPENDS+= proc-macro-error-attr2-2.0.0
CARGO_CRATE_DEPENDS+= proc-macro-error2-2.0.1
CARGO_CRATE_DEPENDS+= proc-macro2-1.0.92
Expand All @@ -299,7 +286,7 @@ CARGO_CRATE_DEPENDS+= rmp-0.8.14
CARGO_CRATE_DEPENDS+= rmp-serde-1.3.0
CARGO_CRATE_DEPENDS+= roff-0.2.2
CARGO_CRATE_DEPENDS+= rustc-demangle-0.1.24
CARGO_CRATE_DEPENDS+= rustc-hash-2.0.0
CARGO_CRATE_DEPENDS+= rustc-hash-2.1.0
CARGO_CRATE_DEPENDS+= rustc_version-0.4.1
CARGO_CRATE_DEPENDS+= rustix-0.38.41
CARGO_CRATE_DEPENDS+= rustls-0.23.19
Expand Down Expand Up @@ -329,7 +316,6 @@ CARGO_CRATE_DEPENDS+= serde_yaml-0.9.34+deprecated
CARGO_CRATE_DEPENDS+= sevenz-rust-0.6.1
CARGO_CRATE_DEPENDS+= sha1-0.10.6
CARGO_CRATE_DEPENDS+= sha2-0.10.8
CARGO_CRATE_DEPENDS+= sha3-0.10.8
CARGO_CRATE_DEPENDS+= sharded-slab-0.1.7
CARGO_CRATE_DEPENDS+= shared_child-1.0.1
CARGO_CRATE_DEPENDS+= shell-escape-0.1.5
Expand All @@ -349,13 +335,12 @@ CARGO_CRATE_DEPENDS+= socket2-0.5.8
CARGO_CRATE_DEPENDS+= spin-0.9.8
CARGO_CRATE_DEPENDS+= spki-0.7.3
CARGO_CRATE_DEPENDS+= stable_deref_trait-1.2.0
CARGO_CRATE_DEPENDS+= string_cache-0.8.7
CARGO_CRATE_DEPENDS+= strsim-0.11.1
CARGO_CRATE_DEPENDS+= strum-0.26.3
CARGO_CRATE_DEPENDS+= strum_macros-0.26.4
CARGO_CRATE_DEPENDS+= subtle-2.6.1
CARGO_CRATE_DEPENDS+= syn-1.0.109
CARGO_CRATE_DEPENDS+= syn-2.0.89
CARGO_CRATE_DEPENDS+= syn-2.0.90
CARGO_CRATE_DEPENDS+= sync_wrapper-1.0.2
CARGO_CRATE_DEPENDS+= synstructure-0.13.1
CARGO_CRATE_DEPENDS+= sys-info-0.9.1
Expand All @@ -366,36 +351,35 @@ CARGO_CRATE_DEPENDS+= tabled_derive-0.9.0
CARGO_CRATE_DEPENDS+= tar-0.4.43
CARGO_CRATE_DEPENDS+= tempfile-3.14.0
CARGO_CRATE_DEPENDS+= tera-1.20.0
CARGO_CRATE_DEPENDS+= term-1.0.0
CARGO_CRATE_DEPENDS+= termcolor-1.4.1
CARGO_CRATE_DEPENDS+= terminal_size-0.4.0
CARGO_CRATE_DEPENDS+= terminal_size-0.4.1
CARGO_CRATE_DEPENDS+= test-log-0.2.16
CARGO_CRATE_DEPENDS+= test-log-macros-0.2.16
CARGO_CRATE_DEPENDS+= thiserror-1.0.69
CARGO_CRATE_DEPENDS+= thiserror-2.0.3
CARGO_CRATE_DEPENDS+= thiserror-2.0.4
CARGO_CRATE_DEPENDS+= thiserror-impl-1.0.69
CARGO_CRATE_DEPENDS+= thiserror-impl-2.0.3
CARGO_CRATE_DEPENDS+= thiserror-impl-2.0.4
CARGO_CRATE_DEPENDS+= thread_local-1.1.8
CARGO_CRATE_DEPENDS+= time-0.3.36
CARGO_CRATE_DEPENDS+= time-0.3.37
CARGO_CRATE_DEPENDS+= time-core-0.1.2
CARGO_CRATE_DEPENDS+= time-macros-0.2.18
CARGO_CRATE_DEPENDS+= time-macros-0.2.19
CARGO_CRATE_DEPENDS+= tinystr-0.7.6
CARGO_CRATE_DEPENDS+= tinyvec-1.8.0
CARGO_CRATE_DEPENDS+= tinyvec_macros-0.1.1
CARGO_CRATE_DEPENDS+= tokio-1.41.1
CARGO_CRATE_DEPENDS+= tokio-1.42.0
CARGO_CRATE_DEPENDS+= tokio-macros-2.4.0
CARGO_CRATE_DEPENDS+= tokio-native-tls-0.3.1
CARGO_CRATE_DEPENDS+= tokio-rustls-0.26.0
CARGO_CRATE_DEPENDS+= tokio-util-0.7.12
CARGO_CRATE_DEPENDS+= tokio-rustls-0.26.1
CARGO_CRATE_DEPENDS+= tokio-util-0.7.13
CARGO_CRATE_DEPENDS+= toml-0.8.19
CARGO_CRATE_DEPENDS+= toml_datetime-0.6.8
CARGO_CRATE_DEPENDS+= toml_edit-0.22.22
CARGO_CRATE_DEPENDS+= tower-service-0.3.3
CARGO_CRATE_DEPENDS+= tracing-0.1.41
CARGO_CRATE_DEPENDS+= tracing-core-0.1.33
CARGO_CRATE_DEPENDS+= tracing-error-0.2.0
CARGO_CRATE_DEPENDS+= tracing-error-0.2.1
CARGO_CRATE_DEPENDS+= tracing-log-0.2.0
CARGO_CRATE_DEPENDS+= tracing-subscriber-0.3.18
CARGO_CRATE_DEPENDS+= tracing-subscriber-0.3.19
CARGO_CRATE_DEPENDS+= try-lock-0.2.5
CARGO_CRATE_DEPENDS+= typeid-1.0.2
CARGO_CRATE_DEPENDS+= typenum-1.17.0
Expand All @@ -411,12 +395,11 @@ CARGO_CRATE_DEPENDS+= unicode-ident-1.0.14
CARGO_CRATE_DEPENDS+= unicode-segmentation-1.12.0
CARGO_CRATE_DEPENDS+= unicode-width-0.1.14
CARGO_CRATE_DEPENDS+= unicode-width-0.2.0
CARGO_CRATE_DEPENDS+= unicode-xid-0.2.6
CARGO_CRATE_DEPENDS+= unsafe-libyaml-0.2.11
CARGO_CRATE_DEPENDS+= untrusted-0.9.0
CARGO_CRATE_DEPENDS+= url-2.5.4
CARGO_CRATE_DEPENDS+= urlencoding-2.1.3
CARGO_CRATE_DEPENDS+= usage-lib-1.3.3
CARGO_CRATE_DEPENDS+= usage-lib-1.3.4
CARGO_CRATE_DEPENDS+= utf16_iter-1.0.5
CARGO_CRATE_DEPENDS+= utf8_iter-1.0.4
CARGO_CRATE_DEPENDS+= utf8parse-0.2.2
Expand All @@ -430,13 +413,13 @@ CARGO_CRATE_DEPENDS+= vte_generate_state_changes-0.1.2
CARGO_CRATE_DEPENDS+= walkdir-2.5.0
CARGO_CRATE_DEPENDS+= want-0.3.1
CARGO_CRATE_DEPENDS+= wasi-0.11.0+wasi-snapshot-preview1
CARGO_CRATE_DEPENDS+= wasm-bindgen-0.2.95
CARGO_CRATE_DEPENDS+= wasm-bindgen-backend-0.2.95
CARGO_CRATE_DEPENDS+= wasm-bindgen-futures-0.4.45
CARGO_CRATE_DEPENDS+= wasm-bindgen-macro-0.2.95
CARGO_CRATE_DEPENDS+= wasm-bindgen-macro-support-0.2.95
CARGO_CRATE_DEPENDS+= wasm-bindgen-shared-0.2.95
CARGO_CRATE_DEPENDS+= web-sys-0.3.72
CARGO_CRATE_DEPENDS+= wasm-bindgen-0.2.99
CARGO_CRATE_DEPENDS+= wasm-bindgen-backend-0.2.99
CARGO_CRATE_DEPENDS+= wasm-bindgen-futures-0.4.49
CARGO_CRATE_DEPENDS+= wasm-bindgen-macro-0.2.99
CARGO_CRATE_DEPENDS+= wasm-bindgen-macro-support-0.2.99
CARGO_CRATE_DEPENDS+= wasm-bindgen-shared-0.2.99
CARGO_CRATE_DEPENDS+= web-sys-0.3.76
CARGO_CRATE_DEPENDS+= web-time-1.1.0
CARGO_CRATE_DEPENDS+= webpki-roots-0.26.7
CARGO_CRATE_DEPENDS+= which-6.0.3
Expand Down
Loading

0 comments on commit fd41a7b

Please sign in to comment.