Skip to content

Commit

Permalink
updpatch: jumpy 0.10.0-1
Browse files Browse the repository at this point in the history
Update several dependencies to pull ring version to 0.17. Upstreamed to quinn-rs/quinn#1751 and fishfolk/bones#334.
  • Loading branch information
hack3ric committed Jan 28, 2024
1 parent 76e0b89 commit 6be5840
Showing 1 changed file with 15 additions and 6 deletions.
21 changes: 15 additions & 6 deletions jumpy/riscv64.patch
Original file line number Diff line number Diff line change
@@ -1,13 +1,22 @@
--- PKGBUILD
+++ PKGBUILD
@@ -19,7 +19,9 @@ options=('!lto')
@@ -19,6 +19,19 @@ options=('!lto')

prepare() {
cd "$pkgname-$pkgver"
- cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+ echo -e "\n[patch.crates-io]\nring = { git = 'https://github.com/felixonmars/ring', branch = '0.16.20' }" >> Cargo.toml
+ cargo update -p ring
+ cargo fetch --locked
+
+ cat << EOF >> Cargo.toml
+[patch.'https://github.com/fishfolk/bones']
+bones_framework = { git = "https://github.com/hack3ric/bones", branch = "archrv-0.3" }
+bones_bevy_renderer = { git = "https://github.com/hack3ric/bones", branch = "archrv-0.3" }
+
+[patch.crates-io]
+quinn = { git = "https://github.com/hack3ric/quinn", branch = "archrv-0.10" }
+quinn-udp = { git = "https://github.com/hack3ric/quinn", branch = "archrv-0.10" }
+EOF
+
+ cargo update -p bones_framework -p bones_bevy_renderer -p quinn -p quinn-udp
+
cargo fetch --locked --target "$(rustc -vV | sed -n 's/host: //p')"
}

build() {

0 comments on commit 6be5840

Please sign in to comment.